What's New in Common - Intergraph Smart 3D - Release Bulletin

Intergraph Smart 3D Release Bulletin

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Release Bulletin
Version_S3D
11.x(2016)

The following changes have been made to the Common task.

Hot Fix and Service Pack Updates

  • The Refresh Reference 3D Interferences command now displays all interferences associated with Reference 3D objects in the workspace. Before, both objects in the interference had to be in the workspace for the interference to display. Now, only one of the two objects needs to be in the workspace. (P2 CP:281320)

  • Information related to the Weight & CG command has been updated. For more information, see Weight & CG. (P2 CP:325421)

Version 2016 (11.0)

  • Added an appendix that details the available units of measure. For more information, see Appendix: Units of Measure.

  • A new tab, Point Cloud, has been added to Filter Properties dialog box. For more information, see Point Cloud (Filter Properties Dialog Box). (P1 CP:246829)

  • You can now use your mouse's scroll wheel to navigate through the QuickPick selection list. This feature allows you to select the exact object that you want without having to move the cursor. In addition to the scroll wheel, you can still use the keyboard arrow keys and ENTER or your mouse to select an object from the QuickPick list. (P1 CP:248411)

  • The Rendering tab in the New View Style dialog box is renamed to Display tab. For more information, see Display Tab (New View Style Dialog Box). (P1 CP:250683)

  • New options have been added to the Synchronize Workspace dialog box. For more information, see Synchronize Workspace with Catalog Dialog Box. (P1 CP:263958)

  • Move and Modify End Features treats unfinished ends of route objects as free end features. For more information, see Move. (P1 CP:267285)

  • To make reading command prompts easier, the status bar can be moved to be below the ribbons and above the graphic views. (P2 CP:38833)

  • You can now add a unit delimiter between primary and secondary units in a report label. For more information, see Unit of Measure Dialog Box (Label Editor). (P2 CP:140982)

  • You can view cable schedule documents in the Design Basis Viewer. The Design Basis Viewer supports a context menu with convenient commands. The Design Basis Viewer is also available when the Electrical task is active. For more information, see Design Basis Viewer Command. (P2 CP:244904)

  • The default background, highlight, and selected element colors have changed. You can customize these colors by selecting Tools > Options, and then selecting the Colors tab. (P2 CP:249730)

  • You can now use the mouse scroll wheel to Zoom In, Zoom Out, and Pan the views without invoking the commands either from shortcut keys or by clicking a toolbar icon. For more information, see Zoom Tool and Pan. (P2 CP:251218)

  • Updated information on PDS Import and Import XMpLant Data. For more information, see PDS Import and Import XMpLant Data. (P2 CP:251249)

  • You can now select templates based on the project mode for new sessions. For more information, see New Dialog Box. (P2 CP:259728)

  • The software now automatically fits in a graphic view the object associated with the To Do List entry that you selected in the listing. For more information, see To Do List Dialog Box. (P2 CP:263920)

  • The Update command on the To Do List dialog box now remains disabled if the object you selected to update has a working status of In Review or Approved, belongs to another global workshare site, or you do not have sufficient permissions to edit the object. (P2 CP:263923)

  • A status bar has been added to the To Do List dialog box that provides immediate feedback to your To Do List operations. (P2 CP:263930)

  • Added a new SmartSketch option, Virtual Box. For more information, see SmartSketch Options. (P2 CP:264306)

  • Added a new option, Lock CTRL key, to the Filter Properties dialog box. For more information, see Filter Properties Dialog Box. (P2 CP:264514, P1 CP:299478)

  • Information related to Paste Dialog Box and Copy and paste an object has been updated. For more information, see Paste Dialog Box and Copy and paste an object (P2 CP:264979)

  • Added a note about the placement of Control Points. For more information, see Control Point. (P2 CP:269823)

  • Information related to PDS Model Reference has been removed. For more information, see Workspace Explorer. (P2 CP:276780)

  • Added the Repair Duplicate Permission Group ID custom command. For more information, see Custom Commands. (P2 CP:278972)

  • Added information about Copy and Paste including a copy of the parent run for route objects. For more information, see Copy and Paste. (P2 CP:273989)

  • Added a new custom command, Placing Supports from XLS. For more information, see Custom Commands. (P2 CP:284643)

  • Updated the keyboard shortcuts for the Fit command. For more information, see Fit. (P2 CP:287993)

  • Added best practice information for using Delete Optional during paste operations. For more information, see Paste. (P2 CP:270710)

  • QuickPick functionality has been updated. You can now activate QuickPick by pressing CTRL and clicking your mouse wheel. You can select items in the QuickPick list by clicking either your left mouse button or your mouse wheel, and you can right-click to close QuickPick. The list displays up to 10 items in the list. (P3 CP:251232)

  • Added the Drawings tab to the Workspace Explorer. For more information, see Workspace Explorer. (P3 CP:271276)

  • Corrected notes on the behavior of messages for the Remove Correlation with Design Basis command. For more information, see Remove correlation with design basis. (P3 CP:295894)

  • For piping and equipment objects in plant mode, Insulation, Equipment Hole, Maintenance, and Operation aspects displaying in the 3D graphic view also display in the Sketch 2D environment. For more information, see Format View Dialog Box. (P4 CP:119768)

  • A new option, Point Grid Display, allows you to specify whether to use point grid spacing. To customize the spacing, specify primary and secondary point spacing on the Point Grid Display tab of the Tools > Options dialog box. For more information, see Format View Dialog Box and Point Grid Display Tab (Options Dialog Box). (P4 CP:260473)

  • A new ribbon, available under Insert > Construction Graphics, allows you to place geometric shapes in the graphic view to stand in for objects that you have not yet drawn or that you do not have permissions to draw. You can now place the following shapes in the graphic view: line, line string, arc, circle, or rectangle. For more information, see Construction Graphics. (P4 CP:262741)

  • Added a note that changes to the piping material class rules do not cause the software to mark pipelines as Out of date in the To Do List. For more information, see To Do List. (P4 CP:270853)

  • Information related to Select by Filter and Filter Properties Dialog Box has been updated. For more information, see Select by Filter and Filter Properties Dialog Box. (P4 CP:272795)

  • Corrected notes on the behavior of original systems when using the Past and Restore command. For more information, see Paste and Restore and Paste Dialog Box. (P4 CP:273368)

  • When defining a workspace, roles now work across all object types and can improve performance. For more information, see Define Workspace Dialog Box and Define roles. (P4 CP:258039)

  • Use the new Load Hierarchy command to view the hierarchy of Reference 3D model objects in the Workspace Explorer. For more information, see Reference 3D Hierarchy in the Workspace Explorer. (P3 CP: 170420)

  • A new Fabrication and Construction category has been added to Reference 3D member part properties so that you can define Construction Type and Construction Requirement property information. For more information, see General Tab (Reference 3D Generic Element Properties Dialog Box). (P2: CP: 286787)

  • The Publish > UpdatePublish command is now called Publish > Update and Publish.

  • Added Include and Exclude commands to the Tools menu for Reference 3D objects with specific model types. An Exclude causes Smart 3D to remove the selected Reference 3D objects from the graphics view, clash reports, drawings, reports, and exports on client and distributed systems in a global workshare environment. For more information, see Exclude and Include Reference 3D Objects. (P2 CP: 276166)

  • You can edit the Approval State of Reference 3D elements by selecting the appropriate status displayed in the Configuration tab of the Reference 3D Generic Element Properties dialog box. For more information, see Configuration Tab (Reference 3D Generic Element Properties Dialog Box). (P2 CP: 287658)

  • Smart 3D has enhanced its anti-alias capabilities for 3D object display by providing high quality, smooth edges in Outline, Smooth Shaded, and Shaded with Enhanced Edges modes. The smooth edge setting is enabled by default. For more information, see Format View Dialog Box. (P2 CP: 290361)

  • For compatibility with the SmartPlant Foundation requirement that specific object properties must have a value, Smart 3D can now update and publish objects with null values for the required properties by providing a base default value. Refer to the Smart 3D-generated log file for more information on the properties containing the added default values. For more information, see Publish documents. (P2 CP: 300947)

Published 14:12 on 3/15/2019