Working with MicroStation Files - SmartSketch - Help

SmartSketch Help

PPMProductFamily
Engineering and Schematics
PPMProduct
SmartSketch
PPMCategory
Help
Version_SPEM_custom
9.0.0
Version_SSK
9.0(2015)

CAD Translators for SmartSketch directly supports MicroStation font and linestyle (*.RSC) resource files, resulting in near perfect visual fidelity when you import, reference, or export MicroStation drawings. Invisible MicroStation information such as database linkages, tag data, and user data is preserved as attributes on SmartSketch graphics. You can even import MicroStation cell libraries as SmartSketch symbols, further enhancing your re-use of existing data.

To use this functionality, you must install the Translators option.

Opening and Saving MicroStation Files

SmartSketch supports opening and saving MicroStation files in two ways: you can either select a MicroStation file and translate it into equivalent SmartSketch elements, or you can create a reference file from a MicroStation file.

If you use the method for selecting a MicroStation file and translating it into equivalent SmartSketch elements, you can click Open on the File menu. After you have opened a MicroStation file using this method, the resulting file is in SmartSketch format (igr).

If the MicroStation file extension is not a .DGN extension, you may need to use a utility to define other extensions as MicroStation files.

If you use the method for creating a reference file from a MicroStation file, you can either click Object on the Insert menu, or you can drag from the Symbol Explorer or Windows Explorer. This action enables you to display and, if MicroStation is available on your PC, edit the MicroStation file while working in SmartSketch. You can also select the view position of a 3-D MicroStation file upon placement. Once a MicroStation file has been referenced using this method, you can then locate and establish relationships between the new information and elements on the drawing sheet.

The Options command on the Tools menu displays the Options dialog box. By selecting the Foreign Data Tab (Options Dialog Box) and setting the format to MicroStation, you can configure the settings for importing MicroStation data that applies to both of these methods.

Roundtrip of MicroStation data (importing MicroStation data to SmartSketch data and exporting back to MicroStation data) is currently supported visually. Data fidelity for information such as tags, database linkages, and user data are not supported during export to the MicroStation file format.

Other Methods for Importing MicroStation Data

You can use the following methods to move MicroStation (.dgn) documents into SmartSketch:

  • Cutting and pasting.

  • Dragging.

  • Inserting the information as an object.

When you open a MicroStation document that has references to other documents, those referenced documents appear as well. You can locate referenced documents in the current document.

You can set placement options by clicking Options on the Tools menu. Then, you can set the options you want on the Reference File tab of the Options dialog box.

Inserting as an Object

Inside SmartSketch, you can insert the entire foreign document with Object on the Insert menu. On the Insert Object dialog box, you can set the option to link or embed the document. After you insert the object, SmartSketch places a SmartFrame border around the object, allowing you to crop it without altering the scale of the object. The software recognizes the geometry of the inserted document. You can use the relationship indicators to draw or create relationships between the geometry of the inserted object and other elements in the SmartSketch document. You can edit the inserted object by double-clicking it.

Object inserts any OLE 2.0-enabled object, such as a Word or .AVI document, or a CAD document, such as .dgn. You can then edit the inserted object by double-clicking it.

If you place dimensions or constraints to items located within a reference file, it is recommended that you do not manipulate those items in the reference file without first deleting the dimension or constraint in the Master file. Such manipulations could cause problems in the Master file.

Saving SmartSketch to MicroStation

You can save a SmartSketch document as a MicroStation document. Before you do this, you can adjust the translation options with Options on the Tools menu. On the Foreign Data tab, you can click Export Options.

When you save SmartSketch document as a .DGN document, the active sheet is saved. On the Options dialog box, you can map SmartSketch layers to MicroStation levels (1–63). All the remaining layers are placed on the last layer or level of the foreign document. The layer names are preserved, whether you are importing or exporting MicroStation documents.

If you save SmartSketch document with raster reference files as MicroStation documents, only the files of the same type (.DGN) can be exported back into.

See Also

Accuracy of MicroStation Data During Import