Place AutoCAD Information in the Document - SmartSketch - Help

SmartSketch Help

PPMProductFamily
Engineering and Schematics
PPMProduct
SmartSketch
PPMCategory
Help
Version_SPEM_custom
9.0.0
Version_SSK
9.0(2015)

To place AutoCAD information on the drawing sheet, you must first open the software and open the document that you want. You should set options for bringing the AutoCAD information into the document with Options on the Tools menu. The options appear on the Foreign Data tab.

To use this functionality, you must install the Translators option.

To Drag a Document

  1. Open the Windows Explorer and select the AutoCAD document that you want.

  2. Drag the document into the current document in the software.

To Insert a Document

  • Click Insert > Object and select the AutoCAD document that you want.

If you place dimensions or constraints to items located within a reference file, it is recommended that you do not manipulate those items in the reference file without first deleting the dimension or constraint in the Master file. Such manipulations could cause problems in the Master file.

To Drag Selected Elements

  1. Open the AutoCAD document and select the elements that you want.

  2. Drag the selected elements into the current document in the software.

If you press Ctrl while you drag a document, the symbol is embedded. If you press Ctrl + Shift, the document is linked.

To Copy and Paste Selected Elements

  1. Open the AutoCAD document and select the elements that you want.

  2. Copy the selected information.

  3. In the software, on the Edit menu, click Paste Special or Copy to copy the selected elements into the current document.

  • You can also open an AutoCAD document directly with Open on the File menu.

  • When you open an AutoCAD document that has references to other documents, those referenced documents appear as well. Nested reference documents can be up to four levels deep. You can locate referenced documents in the current document.

  • After you place the AutoCAD information in the current document, you can locate elements and establish relationships between the new information and elements that you place using the software.

  • When placing translated AutoCAD symbols, all elements of the items that make up the body of the component need to be placed on the default layer of the document.

See Also

Copying and Pasting Elements
Object Command
Options Command