Accuracy of AutoCAD Data During Import - SmartSketch - Help

SmartSketch Help

PPMProductFamily
Engineering and Schematics
PPMProduct
SmartSketch
PPMCategory
Help
Version_SPEM_custom
9.0.0
Version_SSK
9.0(2015)

When you translate AutoCAD data into your document, you are concerned with either visual fidelity or data fidelity or both.

To use this functionality, you must install the Translators option.

Visual Fidelity

Visual fidelity is a phrase used to describe the visual accuracy of a picture after it has been translated. Your software preserves the visual accuracy of an AutoCAD file by providing support for the following seven different areas:

Colors

AutoCAD colors are automatically mapped to the corresponding matching red, green, blue (RGB) color in the color table, resulting in a perfect color match.

Colors that were used in AutoCAD to determine plotting pen widths can also be mapped to a width in your document by using AutoCAD Color on the Line Width tab of the AutoCAD Import Options dialog box.

Widths

AutoCAD R9 through R14 polylines are the only type of entity that support a width. Polyline widths are automatically mapped to an exact matching model width in your document. All other entities such as lines, arcs, and circles in AutoCAD do not support width. For the entities that do not support width, a default width is applied (all elements in your document have a width). You can make changes to any of the default mappings to define your own mapping with the Line Width tab of the AutoCAD Import Options dialog box (accessed through the Foreign Data Tab (Options Dialog Box) after you select Options on the Tools menu). SmartSketch provides a default set of line widths that correspond to standard metric pencil leads: .13, .18, .25, .35, .5, .7, 1.0, 1.4, and 2.0.

Linestyles

AutoCAD default line styles are pre-mapped to the most equivalent line styles for your document on the Linestyle tab of the AutoCAD Import Options dialog box. Line styles other than the default line styles or any complex line styles containing shapes are mapped to continuous unless they are specifically mapped on the Linestyle tab.

Hatches

AutoCAD default hatches are automatically mapped to matching fill styles in your document. Hatches other than the defaults delivered with AutoCAD are stroked into their primitive elements to preserve their visual accuracy.

Font Styles

AutoCAD default font styles are pre-mapped to their most equivalent font styles in your document, True Type Fonts, on the Font tab of the AutoCAD Import Options dialog box. Other fonts default to the Arial true type font delivered with Windows. If the font is not listed in the mapping on the tab, it defaults to Arial.

Xrefs

AutoCAD Xrefs are imported as reference files in your document, which use the automatic defaults or same options for configuring how color, width, line styles, hatches, and fonts are handled for visual accuracy.

Paper Space

If paper space was active when an AutoCAD file was saved, the file containing paper space data causes two sheets to be created when you click Open on the File menu. One sheet represents the paper space data and is named Layout1. The other sheet represents model space data and is named Model. The paper space views are recreated as reference views of the model sheet on the paper space sheet.

AutoCAD files that are reference files instead of files translated using Open on the File menu, do not support the display of paper space data; instead, the model space information is displayed.

Configuring the Fit to Sheet Feature

The software automatically calculates the sheet scale in your document when you import AutoCAD documents so that the range of graphics automatically fits within the lower left-hand corner of the drawing sheet. If you do not want the sheet scale automatically calculated, then you can manually modify the .INI file.

To modify the .INI file, click Explore on the Start menu and go to the folder where SmartSketch resides. You can use any text editor to modify the file. Double-click itacad. In the Options section of the file, set Ignore sheet scale = 0.

You can create a template for calculating sheet scale at the scale you want and insert an AutoCAD document to base the template on. On the Sheet Setup dialog box, you set the Drawing Scale and Paper Units that you want.

Using AutoCAD Fonts and Styles in Your Document

The software supports the system TrueType fonts delivered with Windows and supplies additional ANSI and ISO TrueType™ engineering fonts. When you open a .dwg document, the software provides a default mapping to determine which TrueType font will be assigned to which AutoCAD font. To define your own font mapping, define options on the Font tab of the AutoCAD Import Options dialog box. For more information, see Font Tab (AutoCAD Import Options Dialog Box).

You can also import AutoCAD files containing big fonts used for displaying text in Asian languages. To do this, you must:

  1. Create a text file containing the mappings between the big font and an active font. The text file name must be the same as the big font name. All character mapping text files must have a BigFont Mapping section with entries as follows:

    [BigFont Mapping]
    InputString1 = ASCII Value

    Example entry:
    [BigFont Mapping]
    ~8 = 189; (ASCII Value of fractional value ½)

    SmartSketch replaces the input string occurrence with its corresponding ASCII value when importing the AutoCAD file.

  2. Use the itacad.ini configuration setting BigFonts Location to specify the folder location of the font files and the mapping text files that are used when importing AutoCAD drawings.

Data fidelity

Data fidelity is a phrase used to describe how accurately the data is preserved when compared to its original form in the application that created it. Your document preserves the data accuracy of an AutoCAD file by providing equivalent element types that entities are mapped to. The software also provides support for non-displayed data such as attributes on the resulting elements.

Your document preserves data accuracy of an AutoCAD file by providing support for the following areas:

Units

AutoCAD files are considered unit-less files. The File Units setting for AutoCAD import data on the Options dialog box is used to determine the units for translated AutoCAD data or referenced AutoCAD data.

Coordinates

AutoCAD data is automatically positioned to the matching coordinate positions when you translate the AutoCAD files (click Open on the File menu). Referenced AutoCAD file coordinate positions are determined by the settings on the Reference File tab on the Options dialog box.

You can use Coincident to import the data in its original coordinate position at a 1 to 1 scale.

Layers

Within your document, there are an unlimited number of layers per sheet. AutoCAD layer names are preserved as layer names in your document, but the color and linetype settings are not. The color and linestyle settings are applied directly to the resulting element.

In AutoCAD, colors, line styles, and line widths are applied on a layer-by-layer basis. When you select a different layer, the colors, line styles, and line widths change. In your document, colors, line styles, and line widths are applied directly to each individual element or object. When you select a different layer, the colors, line styles, and line widths are not affected. When you export back to AutoCAD, colors, line styles, and line widths are applied on an entity basis.

AutoCAD entity colors & linetypes are determined one of three ways on an element:

  • Byblock - a property that specifies that an entity inherit the color or linetype of a block containing it. The software does not support the entity concept so the Byblock properties are applied directly to the resulting element.

  • Bylayer - a property that specifies that an entity inherit the color or linetype of its associated layer. The software does not support the entity concept so the Bylayer properties are applied directly to the resulting element.

  • Byentity - occurs when colors and linetypes are directly applied to the entity and override any Byblock or Bylayer properties. The software supports this concept for all of its elements and preserves Byentity properties for colors and linestyles.

Blocks

When translating a .dwg document, the default is to translate blocks into symbols. You can change this default with the Options command on the Tools menu so that blocks are translated into groups. This translates blocks into embedded symbols, or groups, in your document.

When you import an AutoCAD document that has blocks, a temporary folder is created in the Temp folder on your hard drive. The temporary folder contains the symbols that are embedded in the AutoCAD document. By default, these symbols are deleted after the document is imported into the drawing sheet. You can change a setting in the delivered itacad.ini configuration file to save the symbols instead. In Notepad, open the .ini file and change the line in the Options section: Delete Symbol Definitions = 0.

Blocks with Attribute Data

When translating a .dwg document, the default is to translate all blocks containing attribute data into symbols with SmartLabels.

3D Data

All 3D data is flattened into a 2D view when you translate files using Open on the File menu. The 2D view orientation is determined by the Orientation setting in the Import area of the Options dialog box.

The following is an entity to element map when you translate files using Open on the File menu.

AutoCAD

SmartSketch

Line

Line

Circle

Ellipse

Polyline (lines only)

Linestring

Polyline (lines & arcs)

Complex String

Arc

Arc

Trace

Line

Point

Point

Face3d

Line

Solid

Linestring

Block

Symbol

Multiline

Linestring

Spline

Bspline Curve

Dimension

Dimension

Text

Text

Paperspace Viewport

Reference

Xline

Line

Ray

Line

Database Linkages

Dynamic Attribute set on element

Attributes

Dynamic Attribute set on element

Ellipse

Ellipse

Region

Ignored

Solid3d

Ignored

Mtext

Text

Leader

Leader

Tolerance

Group

Xdata

Dynamic Attribute set on the element

Hatch

Fill

Image

Reference

  • The Image Integrator option must be downloaded to support raster reference files.

  • AutoCAD symbols with nested graphics, groups, and complex shapes (for example rectangles) will not translate successfully into SmartSketch symbols. 

  • None of the data that is part of the reference file can be deleted or altered using commands in the software. However, if AutoCAD software is located on your machine, then you can click Open on the Shortcut menu over the reference file. This will open the AutoCAD reference file in the AutoCAD application.

  • If you establish relationships between elements in the SmartSketch file and a reference file, the relationships will be removed if you change the position of elements in the source file and then update the reference file in your document.

  • If you change the inserted information (copied from AutoCAD), the original information does not change.

See Also

Working with AutoCAD Files