Customizing a Toolbar - SmartSketch - Help

SmartSketch Help

PPMProductFamily
Engineering and Schematics
PPMProduct
SmartSketch
PPMCategory
Help
Version_SPEM_custom
9.0.0
Version_SSK
9.0(2015)

Using Extend to Next on the Draw toolbar, you can extend one line to the next line. This command is easy and intuitive to use. However, sometimes you might want to extend a line a specific distance that does not depend on the location of another element.

  1. In the document, place two lines that are not connected, but are perpendicular.

  2. On the Tools menu, click Customize.

  3. On the Customize dialog box, click the Toolbars tab.

  4. In the Categories box, click Custom Commands.

  5. Click Browse.

  6. On the Select Macro Directory dialog box, navigate to the [Product Folder]:\Program\VB Examples\ActxCom\Ribbons\Extend folder, and click extend.ocx.

    If you cannot find the VB Examples folder, you must run a Custom setup and select the Programming Tools option.

  7. Click OK.

  8. On the Customize dialog box, in the Custom Commands box, drag the extend.ocx filename onto the drawing sheet. The filename appears as a separate floating toolbar.

  9. Click Close to close the Customize dialog box.

  10. Drag the floating toolbar over to the top of the window and place it beside the Main toolbar.

  11. On the new toolbar, click Extend.

  12. On the Extend by Distance dialog box, in the Distance box, type 10 and press Enter. The dialog box automatically converts whatever you type into the units of measure that are set for the current document. You can set the units using Properties on the File menu.

  13. In the document, drag the mouse over the line that you want to extend. A preview of what the line will look like shows up in a red color.

  14. Click the line to set the distance.

  15. On the Extend by Distance dialog box, click Close.

You can write your own applications that are very similar to the EXTEND.OCX file and run them from within the current document. Click Start > Programs > Intergraph SmartSketch >  Programming Help to get more information about creating your own macros.

Programming Help is only available if you have installed the Programming Tools option. For more information on installing SmartSketch options, see the Installation Guide available from the Help > Printable Guides command.