How Embedding Works - SmartSketch - Help

SmartSketch Help

PPMProductFamily
Engineering and Schematics
PPMProduct
SmartSketch
PPMCategory
Help
Version_SPEM_custom
9.0.0
Version_SSK
9.0(2015)

When you embed data from another program, the object becomes part of the drawing. When you double-click the embedded object, the software in which the object was created opens so that you can edit it. When you go back to the drawing, the object updates automatically with the changes that you made. The changes, however, exist only in the current drawing.

You can embed existing information or create a new object and then embed it.

Embedding an Object

Suppose you want to use Word to add comments to a drawing. First, click Insert > Object. On the dialog box, click Create New and then click Microsoft Word in the list. After you click OK, Word opens so that you can edit the object. If Word is already open, the new document creates a new window in Word. After you type your notes, click Update on the File menu in Word. You should then switch back to the document or drawing. A box the size of the object appears beside the pointer. You can then click on the drawing sheet to place the Word object and display your notes on the drawing sheet. You can use this same process with any documents created with Office-compatible or OLE- compliant software.

If you want to insert some notes that you already have in a Word document, you can use the Insert > Object command. On the dialog box, you should select Create From File and then enter the name of the Word document to insert the entire document into the host document.

If you want to embed the object, make sure the Link check box is not set.

You can also embed information that you copied from another document. Copy the information, and then switch to the document, and use Paste Special to paste the information as an embedded object.

If you want to use a mouse to embed objects, you can select the information in the source software and then drag it into another document. You can also drag the document that you want to embed from the Windows Explorer or into a document. The object is placed with the mouse drop point at the center of the object.

When dropping documents, you can place the object coincident with the coordinate system of the container document. To do this, select Coincident on the Reference Files tab of the Options dialog box.

Editing an Embedded Object

To edit an embedded object, you can double-click the object to open the software that created the object. The menus and toolbars of the current software are temporarily replaced by the menus and toolbars of the software that just opened.

The software that created both documents must support OLE.

You can also click commands on the shortcut menu to activate the software that created the object. To get the shortcut menu, select the embedded object and then right-click.

See Also

Establish Relationships on a MicroStation Reference File
Change the Source for a Linked Object
Edit an Embedded Object with the Source Software
Embed an Object
Link an Object
Open an OLE Object for Editing
Establish Relationships on an AutoCAD Reference File