Working with AutoCAD Files - SmartSketch - Help

SmartSketch Help

PPMProductFamily
Engineering and Schematics
PPMProduct
SmartSketch
PPMCategory
Help
Version_SPEM_custom
9.0.0
Version_SSK
9.0(2015)

CAD Translators for SmartSketch directly supports True Type Fonts and dashed gap linetypes for outstanding visual fidelity when you import, reference, or export AutoCAD drawings. Invisible AutoCAD information such as database linkages, attributes, and Xdata is also preserved as attributes on SmartSketch graphics.

To use this functionality, you must install the Translators option.

Opening and Saving AutoCAD Files

Your document supports opening and saving AutoCAD files in two ways: you can either select an AutoCAD file and translate it into equivalent SmartSketch elements, or you can create a reference file from an AutoCAD file.

If you use the method for selecting an AutoCAD file and translating it into equivalent elements in your document, you can click Open on the File menu. After you open an AutoCAD file using this method, the resulting file is in SmartSketch format (igr).

If an AutoCAD file contains paper space data, the resulting SmartSketch file contains two sheets: one sheet represents the paper space data, and is named paper space; the other sheet represents model space data, and is named model space. The paper space views are recreated as reference views of the model sheet on the paper space sheet.

If you use the method for creating a reference file from an AutoCAD file, you can either click Object on the Insert menu, or you can drag from the Symbol Explorer or Windows Explorer. This action enables you to display and, if AutoCAD is available on your computer, edit the AutoCAD file while working in SmartSketch. You can also select the view position of a 3-D AutoCAD file upon placement. After an AutoCAD file has been referenced using this method, you can then locate and establish relationships between the new information and elements on the drawing sheet.

The Options command on the Tools menu displays the Options dialog box. By selecting the Foreign Data Tab (Options Dialog Box) and setting the format to AutoCAD, you can configure the settings for importing AutoCAD data that applies to both of these methods.

Roundtrip of AutoCAD data (importing AutoCAD data to SmartSketch data and exporting back to AutoCAD data) is currently supported visually. Data fidelity for information such as attributes, database linkages, and Xdata are not supported during export to the AutoCAD file format.

Other Methods for Importing AutoCAD Data

You can use the following methods to move AutoCAD (.DWG or .DXF) files into SmartSketch:

  • Cutting and pasting.

  • Dragging.

  • Inserting the information as an object.

When you open an AutoCAD document that has references to other documents, those referenced documents also appear. You can locate referenced documents in the current document.

You can also use Open on the File menu to translate and open documents.

Cutting and Pasting

You can select the information in the AutoCAD document and then cut or copy the information and paste it into SmartSketch with Paste Special.

Dragging

You can select the information in the AutoCAD document and then drag it into SmartSketch. In the Windows Explorer, select the AutoCAD document and then drag it into SmartSketch. The document is embedded in the drawing by default. Before you drop the document, you can embed the document in SmartSketch by pressing Ctrl. If you press Ctrl + Shift, the document is linked. When you place the document, handles appear that allow you to scale the object. The foreign document is placed into SmartSketch and behaves much like a symbol, allowing you to click to place it or move it around.

You can set placement options by clicking Options on the Tools menu. Then, you can set the options you want on the Reference File tab of the Options dialog box.

Inserting as an Object

Inside SmartSketch, you can insert the entire foreign document with Object on the Insert menu. On the Insert Object dialog box, you can set the option to link or embed the document. After you insert the object, SmartSketch places a SmartFrame border around the object, allowing you to crop it without altering the scale of the object. The geometry of the inserted document is recognized; you can use the relationship indicators to draw or create relationships between the geometry of the inserted object and other elements in the SmartSketch document. You can edit the inserted object by double-clicking it.

Object inserts any OLE 2.0 enabled object, such as a Word or .AVI document, or CAD document, such as .DWG. The inserted object can then be edited by double-clicking it.

If you place dimensions or constraints to items located within a reference file, it is recommended that you do not manipulate those items in the reference file without first deleting the dimension or constraint in the Master file. Such manipulations could cause problems in the Master file.

Saving SmartSketch to AutoCAD

You can save SmartSketch files as an AutoCAD file. Before you do this, you can adjust the translation options using Options on the Tools menu. On the Foreign Data tab, you can click the appropriate Export Options.

When you save SmartSketch document as a .DWG or .DXF document, the active sheet is saved.

You do not have to map layers for AutoCAD documents; the layer names are imported or exported as named in the native document. If SmartSketch layer has not been mapped, it is automatically placed on the next available layer or level in the foreign document until the last level or layer occurs.

All detail views placed in the document are saved when you save the file as an AutoCAD DWG file. SmartSketch automatically creates a separate sheet in the resulting DWG file that contains detail view(s). The name of each generated sheet corresponds to the name of the sheet in SmartSketch containing the detail view(s). For example, if sheet25 contains one or more detail views in the SmartSketch document, the resulting AutoCAD DWG file will automatically create a sheet named sheet25, which contains the detail view(s). .

See Also

Accuracy of AutoCAD Data During Import
Accuracy of AutoCAD Data During Export