How Linking Works - SmartSketch - Help

SmartSketch Help

PPMProductFamily
Engineering and Schematics
PPMProduct
SmartSketch
PPMCategory
Help
Version_SPEM_custom
9.0.0
Version_SSK
9.0(2015)

Suppose you are sketching a drawing and you want to include it in an engineering change request that was created in Word. You intend to update the drawing several times and want the change request to reflect the latest updates. A good way to keep the updates current is to link the drawing to the Word document and then periodically update the link.

Creating a Link

You can create links between documents as easily as you cut and paste information. To create a link to an entire document, you insert information into the destination document with Object on the Insert menu. This is convenient when you do not want to switch away from the document in which you are currently working.

You can also link information by dragging and dropping the document from the Windows Explorer into your document.

To insert the document as a linked object, you must press CTRL + SHIFT while dragging and dropping the document; otherwise, the document is embedded.

To create a link to just part of a document, copy the information in the source document and then use Paste Special in the destination document to create the link. To establish the link, you must save the destination document. The software that created both documents must support OLE.

Reconnecting or Changing a Link

When you move a document or rename the source document, the links in the destination document are broken. To reconnect the link to the source document or change the link to another document, you can click Links on the Edit menu.

Updating a Link

Suppose you linked revision notes in a Word document to your drawing. You have revised your notes in Word since you first created the link. You must now update the link in the document so that it displays the latest revisions to your notes. You can specify whether the updates happen automatically when you change the Word notes or if you must manually update the link in your original document. First, click Links on the Edit menu and then, on the Links dialog box, select the link that you want to set. You can then click Automatic or Manual. With Automatic set, the software updates the links every time you open the document. With Manual set, the software updates the links only when you click Update Now on the Links dialog box.

Editing Linked Information

The best way to edit linked information is to change it in the source document. To edit the linked information, double-click on the linked object.

If you place dimensions or constraints to items located within a reference file, it is recommended that you do not manipulate those items in the reference file without first deleting the dimension or constraint in the Master file. Such manipulations could cause problems in the Master file.

Breaking a Link

If you do not need to automatically update the information displayed in the destination document, you can break the link using Links on the Edit menu. Once the link is broken, the information still appears in the destination document, but you cannot update the information or reconnect the link. You must create a new link instead.

See Also

Object Command
Paste Special Command
Change the Source for a Linked Object
Edit an Embedded Object with the Source Software
Break a Connection to a Linked Object
Link an Object