Embed an Object - SmartSketch - Help

SmartSketch Help

PPMProductFamily
Engineering and Schematics
PPMProduct
SmartSketch
PPMCategory
Help
Version_SPEM_custom
9.0.0
Version_SSK
9.0(2015)

To Embed a New Object

  1. Click Insert > Object.

  2. On the Insert Object dialog box, click Create New.

  3. In the Object Type box, click the type that describes the software in which you want to create the object, and then click OK.

    The contents of the list depend on which applications installed on your computer support linking and embedding.

  4. To return to the host application, do one of the following:

    • If the object was created in another application that is in a separate window, click Exit or Update on the File menu in that application. If a message appears asking if you want to update the document, click Yes.

    • If the software temporarily replaces some of the menus and toolbars, click anywhere outside the embedded object.

    • When you return to the host application, a box the size of the object appears beside the pointer. You can click on the drawing sheet to place the object that you edited or created. While the box appears beside the pointer, if you press the ESCAPE key, the object will be placed at the default location. You can set the default location with the Tools > Options command. You enter the location on the File Locations tab of the Options dialog box.

To Embed an Existing Object

  1. Click Insert > Object.

  2. On the Insert Object dialog box, click Create from File.

  3. In the File box, type or click the name of the object you want to embed, and then click OK.

If you do not see the file to embed, click a different drive or folder.

A box the size of the object appears beside the pointer. You can click on the drawing sheet to place the object that you edited or created.

While the box appears beside the pointer, if you press the ESC key, the object will be placed at the default location. You can set the default location using the Tools > Options command. You enter the location on the File Locations tab of the Options dialog box.

  • If you are working in the source software, you can embed an existing object using the Edit > Paste Special command.

  • You can also embed an object by dragging and dropping a document from the Windows Explorer into a document.

  • If you insert a document into the current document, the terminators, spaces, text, and styles appear in paper units relative to the source document. The dimension lines and extension lines scale as though they are in real-world units. This behavior can cause the dimensions and text to appear very large or small in the container document.

See Also

Object Command
How Embedding Works
Paste Special Command