Tools - Intergraph Smart 3D - Help

Intergraph Smart 3D Catalog

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Help
Version_S3D
12.x(2018)

This section describes all the major tools and commands used to manage catalog and reference data changes.

Bulkload Utility

Bulkload allows you to load changes from spreadsheets into the catalog database. Select Add, modify, or delete records in existing catalog to modify existing data in the catalog. For more information, see Bulkload Utility in the Smart 3D Reference Data Guide.

Verify Consistency Report Command

Tools > Verify Consistency Report checks the piping specification rules and the required data to place the part occurrences. After the consistency check completes, the software generates a report detailing the discrepancies. For more information, see Verify Consistency Report Command under Piping Reference Data > Consistency between Piping Specification and Catalog Data in the Catalog User's Guide.

Catalog Checker Utility

Catalog Checker assesses how changes made to the specification rules and part data in the catalog impact the 3D model. For more information, see the Smart 3D Customer Support Site under the Freeware Tools and Utilities web page at https://smartsupport.intergraph.com.

Synchronize Model with Catalog Command

Synchronize Model with Catalog updates all objects in the model database with all catalog changes, such as part definition, specification, rules, and symbol definition changes. For example, in a GWS configuration, you need to update the To Do List with items at satellite locations. We recommend that you select Mark out-of-date occurrences as shown below. For more information, see Synchronize Model with Catalog in the Smart 3D Project Management User’s Guide.

Synchronize Workspace Command

Synchronize Workspace updates selected out-of-date objects in the model with all changes from the catalog. If no objects are selected, then the command searches and updates all out-of-date objects in the workspace. You access this command by selecting Tools > Utilities > Synchronize with Catalog. For more information, see Synchronize Workspace in the Smart 3D Project Management User’s Guide.

To Do List

To Do List shows objects in the workspace that have inconsistent data. The Note column describes the problem. Select View > To Do List in any modeling task to run the command. For more information, see the Smart 3D Common User’s Guide.

Update Custom Symbol Configuration Command

Update Custom Symbol Configuration updates the CustomSymbolConfig.xml file, which contains the ProgID, CLSID, and dll name for each custom symbol. Smart 3D uses this file to find the symbol dll when the software creates the symbol definition object for the first time in the model database. Select Tools > Update Custom Symbol Configuration in the Project Management task to run this command. For more information, see the Smart 3D Common User’s Guide.

Smart 3D Schema Browser

Smart 3D Schema Browser allows you to check the success of an intended schema change and diagnose problems with the catalog schema. This tool is located at [Product Folder]\Core\Tools\Administrator\Bin\MetaDataBrowser.exe.