Requirements and Recommendations - Intergraph Smart Interop Publisher - Release Bulletin

Intergraph Smart Interop Publisher Release Bulletin

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart Interop Publisher
PPMCategory
Release Bulletin
Version_SPIOP
13.x(2019)

Hardware and Software Requirements

  • Intel® Core i7 processor or equivalent

  • Four Processor Core minimum. If you plan on using batch services for remote systems to do the translations, then the batch systems must also meet this processor core requirement.

  • 8 GB RAM

  • DVD drive access, either locally or through a network connection

  • 400 MB minimum free disk space

  • Microsoft Office (32-bit or 64-bit versions); required for translation

  • A workstation class graphics card; even in a Cloud configuration, this card is required for the Occlusion translation option. For more information on the Occlusion option, refer to Common Options in the Smart Interop Publisher User's Guide.

Supported Operating Systems

  • Microsoft Windows Server 2019

  • Microsoft Windows Server 2016 (64-bit)

  • Microsoft Windows 7 Professional and Enterprise Client (64-bit)

  • Microsoft Windows 10 (ver. 1803 or later) Professional and Enterprise Client (64-bit)

    Beginning with Windows 10, Microsoft will enforce the Internet Host Table Specification RFC 952, which mandates that component hostname labels can contain only alphanumeric characters. Host names using underscores (‘_’) are not allowed. Refer to Microsoft KB 101785.

Licensing and Modules

  • SRP - Intergraph Smart Interop Publisher translation license. You can purchase a single translation license, which enables the sequential translation of source files, or you can purchase multiple licenses to support concurrent translations. Contact your Intergraph Consultant for more information.

  • SIP - Intergraph Smart Interop Publisher Adaptor-to-SmartPlant Foundation module license. In addition to translation, this license provides functionality for the SmartPlant Foundation module to register, revise, and publish to a SmartPlant Foundation site.

    If you purchase a SIP module and license, SmartPlant Foundation, SmartPlant Client, and the SmartPlant Client Schema Component are supported.

  • MCD - Intergraph Smart Interop Publisher Mechanical Computer-Aided Design (MCAD) module license. This license is required if you purchase the MCAD module for Smart Interop Publisher.

  • IFC - Intergraph Smart Interop Publisher Industry Foundation Classes license. This license is required if you purchase the IFC module that allows Smart Interop Publisher to translate source files and then export them to a non-Intergraph .ifc target format.

  • Licensing:

    • SmartPlant License Manager Client and Server 2012

      -OR-

    • Intergraph Smart® Licensing 2019

Scheduling

  • Intergraph Batch Services 2010 SP1 HF 06.01.09.00

Software Compatibility

For the most current information on Smart Interop Publisher and supported products, see the PPM Compatibility Matrix - Product Report on Intergraph Smart Support: https://smartsupport.intergraph.com. Go to the website and type your Smart Support user name and password. From the View Downloads page, click the Product Compatibility link. Select Smart Interop Publisher, and then the version number.

Target applications:

  • Smart 3D 2018

  • Smart Review 2018

  • SmartPlant Foundation

    • SmartPlant Foundation Desktop Client 2018 R1

    • SmartPlant Foundation Web Client 2018 R1

    • SmartPlant Schema Component 2018 R1

    • SmartPlant.NET 2018 R1

      • SmartPlant Client.Net

      • SmartPlant SchemaComponent.Net

      • Integration Schema Files

        For Smart Interop Publisher to publish to the SmartPlant Foundation target, you must select and load the SmartPlant Client.Net, SmartPlant SchemaComponent.Net, and Integration Schema Files options in the SmartPlant Foundation installation.

  • Portal

    • HxGN SDx Projects 2018 R1

    • SDx Projects 2018 R1

  • Alias ISOPAC 2.x (included with Smart Interop Publisher)

  • Citrix XenApp 7.15

  • Microsoft Office 2019 or 365 (32-bit or 64-bit versions)

  • Microsoft Access 2013 and 2016

  • Microsoft SQL Server 2016 SP2 Express/Standard/Enterprise Edition (64-bit)
    Microsoft SQL Server 2017 Express/Standard/Enterprise Edition (64-bit)

  • Microsoft Visual C++ Redistributable Packages:

    • Microsoft Visual C++ 2008 SP1 (32-bit)

    • Microsoft Visual C++ 2010 SP1 (32-bit)

    • Microsoft Visual C++ 2013 with Update 2 (32-bit)

    • Microsoft Visual C++ 2015 (64-bit)

  • Microsoft Data Access Components (MDAC) 2.8.1 (Available on the product CD.)

    If you are running Smart Interop Publisher on a non-English operating system and locale, you must download the appropriate locale-specific version of the Microsoft Data Access Components (MDAC) from Microsoft. Smart Interop Publisher might not work correctly with multi-byte characters when using the English version of MDAC.

  • Microsoft .NET Framework 4.7.2. You must go to the Microsoft Dowload Center to install the required .NET Framework version.

  • Google Chrome, Safari, or Microsoft Edge

  • A PDF reader (Required to view the License Agreement and printable guides.)

System Permissions

You must have administrator privileges to install Smart Interop Publisher. Administrator privileges are not required to translate files.