Installation of Required Software - j5 - 28.0 - Help - Hexagon PPM

j5 Wonderware Historian Datasource Connector Help

Language
English (United States)
Product
j5
Search by Category
Help
j5 Version
2019

The following versions of software are supported with j5 Wonderware Historian Interface:

  • j5 Framework 2018

  • j5 Framework 2017.2: any version later than 25.0.27955.0 (built June 12, 2018)

  • Wonderware System Platform 2014 R2 SP1

  • Wonderware System Platform 2017 Update 2

There are known issues connecting to the WW Historian when the historian database is on certain MS SQL builds.

The issues manifest on the client side as similar to the following:

  • ‘08S01’, ‘[08S01] [Microsoft][ODBC Driver XX for SQL Server]TCP Provider: An existing connection was forcibly closed by the remote host

  • (SQLExecDirectW); [08S01] [Microsoft][ODBC Driver XX for SQL Server]Communication link failure (10054)’)

In the SQL Server logs, the error will manifest as an Access Violation with a code of 17310 or 17311 or Similar

  • If using SQL 2016, please ensure that the following or newer is installed on the Historian MS SQL Server: Cumulative Update 4 for SQL Server 2016 SP2.

  • If using SQL 2017, please ensure that the following or newer is installed on the Historian MS SQL Server: Cumulative Update 4 for SQL Server 2017.

It is not recommended to run Wonderware Historian on an MS SQL Server version less than SQL 2016.