Database management system - j5 - 28.0 - Installation & Upgrade - Hexagon PPM

j5 Installation and Upgrade

Language
English (United States)
Product
j5
Search by Category
Installation & Upgrade
j5 Version
2019

A connection to one of the following databases is required:

  • Microsoft SQL Server (2019, 2017, 2016SP2, 2014SP3)

    • This requires MSODBCSQL 17.X to be installed before running setup. It is shipped alongside j5 and located here: c:\Program files (x86)\j5\framework\msodbcsql

    • If MSODBCSQL 17.X is installed during j5 setup, j5 setup may fail, in which case you need to run j5 setup again.

  • Microsoft Azure SQL Database (V14 - PaaS, V13, V12)

  • Oracle Database (19c, 18c, 12c Release 2)

  • PostgreSQL (9.4 - 11) - including any minor releases of a supported PostgreSQL version (e.g. 9.5.x, 10.x)

For development instances, the following databases are supported:

  • Microsoft SQL Server Express (2017, 2016, 2014)

When using Microsoft SQL Server Express for a development instance the following limitations apply:

  • 1GB maximum memory used by the SQL Server Database Engine.

  • The maximum size of each relational database is 10GB.

  • SQL Agent is not included in Express. The SQL Agent is a background tool which enables administrators to automate tasks like backing up data, database replication setup, job scheduling, user permissions, and database monitoring.

  • The limit on the buffer cache for each instance is 1MB of RAM.

  • The relational database engine is restricted to the lesser of 1 socket or 4 cores.

  • Additional limitations on RDMS performance such as no I/O Resource Governance.