Prerequisites - Intergraph Smart P&ID - Installation & Upgrade - Intergraph

SmartPlant P&ID Installation and Upgrade Guide

PPMProduct
Intergraph Smart P&ID
PPMCategory_custom
Installation & Upgrade
SPFVersion_custom
Version_SPEL_custom
2015 R1 (7.1)
Version_SPI_custom
(none)
Version_SPPID_custom
7.1 (2014 R1)
Version_SPEM_custom
7.2 (2014 R2)
Version_WebSPID
(none)
  • Make sure that a compatible Oracle server version is installed.

  • Set up your client Windows regional and language options as you require.  You can only set up these options before the client installation. If you want to change the regional and language options after the installation, you will have to reinstall the Oracle client for the changes to take effect.

  • For the current version of SmartPlant P&ID, Microsoft .Net Framework 4.0 must be installed before installing Oracle client. If Oracle client was installed before .Net Framework, you may see the following message when opening Drawing Manager:

    To fix the problem, do the following:

    1. Uninstall Oracle client.

    2. Install Microsoft .Net Framework 4.0 (delivered on the SmartPlant P&ID DVD layout).

    3. Install Oracle client.