This troubleshooting topic only applies to those installing retired SmartPlant Markup
Plus versions 2019 SP 1 or prior.
Error Message
An error similar to the following appears when you try to restart the Apache Tomcat service after updating Java on the server where SmartPlant Markup Plus is installed:
Windows could not start the Apache Tomcat on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, or refer to a service-specific error code 1.
The Apache Tomcat log files also contain error messages similar to the following:
[2015-09-29 10:42:20] [error] [ 3752] Failed creating java C:\Program Files (x86)\Java\jre7\bin\client\jvm.dll
[2015-09-29 10:42:20] [error] [ 3752] The system cannot find the path specified.
[2015-09-29 10:42:20] [error] [ 3752] ServiceStart returned 1
[2015-09-29 10:42:20] [error] [ 3752] The system cannot find the path specified.
The default log file location is [installation location]\Apache Software Foundation\Tomcat [version]\logs.
Possible Cause
Apache Tomcat is trying to use a previous unsupported version of Java.
Solution
Configure Apache Tomcat to use the version of Java Runtime Environment that is installed on your server.
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Navigate to the [installation location]\Apache Software Foundation\Tomcat [version]\bin folder.
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Run Tomcat[version]w.exe.
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In the Apache Tomcat [version] Tomcat[version] Properties dialog box, click the Java tab.
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In the Java Virtual Machine box, enter the location of the latest jvm.dll. For example, C:\Program Files (x86)\Java\jre1.8.0_60\bin\client\jvm.dll.
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Restart the Apache Tomcat service.