Server is running out of memory - SmartPlant Markup Plus - Version 2019 SP 1 (10.0.1) - Installation & Upgrade

SmartPlant Markup Plus Installation

Language
English (United States)
Product
SmartPlant Markup Plus
Search by Category
Installation & Upgrade
SmartPlant Foundation / SDx Version
10
SmartPlant Markup Plus Version
10.0 (2019)

Problem

The SmartPlant Markup Plus server is running out of memory.

Cause

This problem might occur if too many log files are being generated.

Solution

Stop the Brava! Enterprise Server log files from being generated:

  1. Log on to the SmartPlant Markup Plus server as an administrator.

  2. Open the logback.xml file delivered to the [installation location]\Apache Software Foundation\Tomcat[Version]\webapps\BravaServer\WEB-INF\classes folder.

  3. Comment uncommented elements by adding commenting brackets (<!-- and -->).

Stop the Apache Tomcat log files from being generated:

  1. Log on to the SmartPlant Markup Plus server as an administrator.

  2. Open the server.xml file delivered to the [installation location]\Apache Software Foundation\Tomcat[Version]\conf folder.

  3. Comment the following element by adding commenting brackets (<!-- and -->).

            <!-- <Valve className="org.apache.catalina.valves.AccessLogValve" directory="logs"

                   prefix="localhost_access_log." suffix=".txt"

                   pattern="%h %l %u %t &quot;%r&quot; %s %b" /> -->

  4. Restart the Apache Tomcat service.