Windows could not start the Apache Tomcat on Local Computer - SmartPlant Markup Plus - Version 2019 SP 1 (10.0.1) - Installation & Upgrade

SmartPlant Markup Plus Installation

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English (United States)
Product
SmartPlant Markup Plus
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Installation & Upgrade
SmartPlant Foundation / SDx Version
10
SmartPlant Markup Plus Version
10.0 (2019)

Error Message

An error similar to the following appears when you try to restart the Apache Tomcat service after updating Java on the server where SmartPlant Markup Plus is installed:

Windows could not start the Apache Tomcat on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, or refer to a service-specific error code 1.

The Apache Tomcat log files also contain error messages similar to the following:

[2015-09-29 10:42:20] [error] [ 3752] Failed creating java C:\Program Files (x86)\Java\jre7\bin\client\jvm.dll

[2015-09-29 10:42:20] [error] [ 3752] The system cannot find the path specified.

[2015-09-29 10:42:20] [error] [ 3752] ServiceStart returned 1

[2015-09-29 10:42:20] [error] [ 3752] The system cannot find the path specified.

The default log file location is [installation location]\Apache Software Foundation\Tomcat [version]\logs.

Possible Cause

Apache Tomcat is trying to use a previous unsupported version of Java.

Solution

Configure Apache Tomcat to use the version of Java Runtime Environment that is installed on your server.

  1. Navigate to the [installation location]\Apache Software Foundation\Tomcat [version]\bin folder.

  2. Run Tomcat[version]w.exe.

  3. In the Apache Tomcat [version] Tomcat[version] Properties dialog box, click the Java tab.

  4. In the Java Virtual Machine box, enter the location of the latest jvm.dll. For example, C:\Program Files (x86)\Java\jre1.8.0_60\bin\client\jvm.dll.

  5. Restart the Apache Tomcat service.