Error Messages
When using a browser to view a drawing created with a Hexagon authoring tool, you receive one or both messages:
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Fonts missing or corrupt. Using default font.
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Unable to view file. Default font is missing.
If the drawing cannot be displayed with the fonts used in the file, the software tries to display the drawing using a default font. If the drawing cannot be displayed with the default font, the software will not display the drawing.
Common Causes
When displaying Hexagon drawings, the software uses the fonts installed on the SmartPlant Foundation File Server.
The SmartPlant Foundation File Server is the computer that hosts the SmartPlant Foundation File Service software and is where Smart Interop Publisher is installed. Usually, the SmartPlant Foundation Application Server hosts the file service software. If a separate server hosts the file service software, that server is called the SmartPlant Foundation File Server.
These errors occur when the font is:
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Not installed on the server.
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Is installed on the server but is corrupted.
Solution
All fonts are managed using tools provided with the operating system. Modifying font settings on a server can cause problems for any file opened by any application that relies on the installed fonts.
Determine which fonts are unavailable:
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On the client computer, try to view the drawing again.
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Review the browser's console log. You will see messages similar to these:
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Files for font(s) ARIALN.TTF, arial.ttf, RomaC Bold.ttf, arialbd.ttf are missing or corrupt. Defaulting to Arimo-Regular.ttf.
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Default font file Arimo-Regular.ttf is missing or corrupt. Unable to view file.
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Add unavailable fonts to the SmartPlant Foundation File Server:
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Log on to the SmartPlant Foundation File Server as an administrator.
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Open the following folder:
[drive]:/\SmartPlant Foundation Server Files\SPFWebClient_Sites\[Site Name]\viewers\goview\goview\resources\fonts directory
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If any of the unavailable fonts do not appear in the directory, add them.