Smart Instrumentation Example: Mapping New Enumerated List Entries Starting in the Tool - Intergraph Smart Instrumentation - 13.1 - Customization & Programming - Intergraph

Intergraph SmartPlant Enterprise SmartPlant Adapter for Smart Instrumentation

Language
English (United States)
Product
Intergraph Smart Instrumentation
Search by Category
Customization & Programming
SmartPlant Foundation / SDx Version
10
Smart Instrumentation Version
13.1

The following topic provides an example of adding and defining mapping for a new enumerated list entry for the Instrument Status list in Smart Instrumentation.

Before You Update the Smart Instrumentation Database

  1. Make a backup of the SmartPlant Foundation site database and any vaults for the site.

  2. Make a backup of the Smart Instrumentation database and the INtoolsMap.xml file located in the SmartPlant resources folder.

Create the List Entry in the Instrument Status Table

  1. Click Start > All Programs > Intergraph Smart Instrumentation > Smart Instrumentation.

  2. Log on to Smart Instrumentation.

  3. In the Open dialog box, expand the appropriate plant, and then select the lowest level in the hierarchy.

  4. Click OK.

  5. Close Domain Explorer.

  6. Click Modules > Instrument Index.

  7. Click Tables > Instrument Statuses.

  8. In the Instrument Statuses dialog box, click New to define the new enumerated list item.

  9. In the Instrument Statuses dialog box, type PRC as the instrument status and Preconstruction as the description, and click OK.

  10. To verify the new instrument status has been added, click Reports > Tables > Instrument Statuses. Find the new PRC values in the report that appears.

  11. Click File > Exit, and when prompted, confirm that you want to close your Smart Instrumentation session.

Load the Smart Instrumentation Tool Map Schema

  1. In the Desktop Client, set your scope for the applicable plant, and then find the CMF file.

  2. Right-click the CMF file, and then click Edit > Check Out.

  3. Click OK in the Check Out dialog box.

  4. In the New Items window, right-click the new version of the CMF file, and select Launch Schema Editor.

  5. On the Set Active Configurations dialog box, select the schema version that you want to view.

  6. Click the Advanced tab and add any further options you require.

    The Description field and the Select Criteria field can be blank, but if you add a value to one you must add the identical value to the other.

  7. Click OK to set the configuration.

    • By default, changes to the SmartPlant Schema are written to all versions managed by the CMF file. You can choose to write changes to only selected versions; however, that is not recommended.

    • If you choose to view one version of the schema (Specify configurations to display window) but write changes to all versions (Set Configurations for new objects window), an information window appears when you click OK, indicating that you will be prompted with every change to the schema to confirm that you want to write the changes to all versions. Click OK to continue.

      The CMF file must be checked in to SmartPlant Foundation before users can publish from an authoring tool.

  8. Under Startup options, select the Load map schema and Connect to application schema check boxes, and click OK.

  9. In each row in the Synchronize dialog box, the values in the tool database and tool map schema columns indicate actions to correct inconsistencies between the tool metadata and tool map schema. Select the appropriate action in each row, and then click OK.

    • Each row represents a discrepancy between the tool database and the tool map schema.

    • Default actions are blue when the Synchronize dialog box appears. However, if you select a different option, it will become blue instead.

    • In many cases, only one operation is supported to synchronize the tool database and tool map schema. For example, if a new property was found in the database, the metadata adapter can add the property to the tool map schema, but it cannot remove the property from the tool database.

Add the New Status Entry to the SmartPlant Schema and Map

  1. In the Map Environment, expand Smart Instrumentation > Loaded Map Schemas > INtools Tool Schema.

  2. Expand the Map Enumerated Lists node, and right-click Construction Statuses.

    Construction Statuses is called Instrument Status in Smart Instrumentation.

  3. Select Edit Construction Statuses.

  4. Select the Publish tab.

  5. In the SmartPlant section of the Edit Enumerated List Definition dialog box (upper, right corner), expand the tree, and click Construction state > New > New.

  6. Right-click New, and select Create New EnumEnum.

  7. In the New Enumerated Entry dialog box, type a name and description for the new preconstruction enumeration in the SmartPlant schema.

  8. Click OK.

  9. In the SmartPlant tree, select Construction state > New.

  10. Under Unmapped application enumerations, select Preconstruction.

  11. Under Unmapped SmartPlant enumerations, select Preconstruction.

  12. Click Map .

  13. Click OK.

Save the Tool Map Schema and SmartPlant Schema Changes

  • Click File > Save All Modified Files to save the SmartPlant schema changes (CMF file) and the tool map schema.

  • When you close the Schema Editor, the software prompts you to save your connection information, user interface options, and loaded tool map schemas to a session file. Click Yes in the message box to save the session file so that you can use it to return to this working environment. However, you should not open a session file after launching the CMF file from the Desktop Client.

  • If you save changes to the CMF file or a tool map schema but did not validate the changes before exiting, the software displays an information message to remind you that the file contains changes that have not been validated. Click OK to dismiss the message.

  • If you make changes to the SmartPlant schema, you must load the changes into the SmartPlant Foundation database.

  • Additionally, if you made changes to the SmartPlant schema, you should regenerate the component schemas for the site before testing any publish or retrieve mapping relationships. For more information, see the SmartPlant Schema Editor User's Guide.