Smart P&ID Database Server - Intergraph Smart P&ID - 10.0 - Installation & Upgrade - Intergraph

Intergraph Smart P&ID Installation and Upgrade

Language
English (United States)
Product
Intergraph Smart P&ID
Search by Category
Installation & Upgrade
Smart Electrical Version
10
Smart P&ID Version
10
Smart Engineering Manager Version
11

Hardware Recommendations

For details of the recommended hardware configuration for the Smart P&ID database server, see Smart P&ID Project Hardware Sizing Recommendations.

Supported Operating Systems

  • Microsoft Windows Server 2016 - Standard and/or Enterprise Server

  • Microsoft Windows Server 2019 - Standard and/or Enterprise Server

  • Linux 7.5

Remote Client Server Operating System

  • Microsoft Windows Server 2016 - Standard and/or Enterprise Server

  • Microsoft Windows Server 2019 - Standard and/or Enterprise Server

Supported Database Servers

  • Oracle 18.3 - Standard Edition and/or Enterprise Edition

  • Oracle 19.3 - Standard Edition and/or Enterprise Edition

  • Oracle for Linux 19.3.0.*

  • Microsoft SQL Server 2017 - Standard Edition and/or Enterprise Edition

  • Microsoft SQL Server 2019 - Standard Edition and/or Enterprise Edition

  • Microsoft Azure SQL Database - 2019

Beginning with Windows 10 and Oracle 12.1.0.2, Microsoft and Oracle will enforce the Internet Host Table Specification RFC 952 which mandates that component hostname labels can contain only alphanumeric characters. Host names using underscores (‘_’) are not allowed. Refer to Oracle Support Articles 1603775.1 and 1957895.1 and Microsoft KB 101785.

The following editions of Oracle Database Server are available:

  • Standard Edition — For department or workgroup level applications, or for small-to-medium sized enterprises (SMEs). It is engineered to provide core relational database management services and options. If you select this installation type, you must purchase additional licenses if you want to install extra Enterprise Edition options.

  • Enterprise Edition — For enterprise-level applications. It is engineered for mission-critical, high-security online transaction processing (OLTP) and data warehousing environments. If you select this installation type, all separately licensable Enterprise Edition options are installed.

If working with Smart P&ID connected workshare configuration, the Standard Edition of Oracle will suffice. If SmartPlant 3D workshare will also be implemented on this database server, then the Enterprise Edition is required.

For additional details regarding platform support, please review the latest compatibility matrix available on PPM Smart Community. If you cannot access the compatibility matrix, contact customer support.