Loading Smart P&ID Prerequisite Software - Intergraph Smart P&ID - 10.0 - Installation & Upgrade - Intergraph

Intergraph Smart P&ID Installation and Upgrade

Language
English (United States)
Product
Intergraph Smart P&ID
Search by Category
Installation & Upgrade
Smart Electrical Version
10
Smart P&ID Version
10
Smart Engineering Manager Version
11

Install any required prerequisite software which is not yet installed on your computer. The following software is required:

  • Intergraph Smart® Licensing 2019 or latest.

  • Microsoft .NET Core 2.2.

    If Microsoft .NET Framework is not installed on your machine, you must download and install it before you can proceed with the Smart P&ID installation.

  • Microsoft Visual C++ 2017 for automation.

  • In order to use the Piping Specification Utility with Smart 3D, you must install the Intergraph Smart 3D S3DPIDClient. For details, see Install Intergraph Smart® 3D S3DPIDClient.