Smart API server machine - Intergraph Smart Instrumentation - 2.2 - Installation & Upgrade

Intergraph Smart Instrumentation Smart API Installation and Configuration Guide

Language
English (United States)
Product
Intergraph Smart Instrumentation
Search by Category
Installation & Upgrade
Smart Instrumentation Web Version
2.2

Hardware Recommendations

We recommend installing the software on a computer having a 2.9 GHz processor and 4 GB of RAM. For additional details regarding platform support, please review the latest compatibility matrix available on Intergraph Smart Support. If you cannot access the compatibility matrix, contact customer support.

Recommended Disk Space

Full installation of Smart API software: 0.4 GB

Additional disk space is required for software prerequisites and optional software that you install.

Supported Operating Systems

  • Microsoft Windows Server 2012 R2

  • Microsoft Windows Server 2016

  • Intergraph Smart® Smart APIs are certified on Windows with UAC ‘On’ at Level 3 (Default)

Software Prerequisites

  • Internet Information Services (IIS) 8.5 or higher, configured for API use

  • Intergraph Smart® Licensing Client 2019

  • SmartPlant® Instrumentation 2016 SP1 or higher.

    • 2016 HF12 or higher is required for working with report related requests

    • 2018 HF2 or higher is required for working with EDE related requests

Supported Database Clients

  • MS SQL Client 2014 (for SPI 2016 SP1 HF12 or higher)

  • MS SQL 2016 (for SI 2018 HF1)

    The client is installed along with the SQL server software and is not a separate installation.

  • Oracle 12c R1 client (12.1.0.2) Patch 2. 32-bit client required for both 32-bit and 64-bit Oracle databases