Create a Single Component Rule - Intergraph Smart Instrumentation - Help

Intergraph Smart Instrumentation Rule Manager Help

Language
English
Product
Intergraph Smart Instrumentation
Search by Category
Help
Smart Instrumentation Version
14
  1. In the tree view, select the folder you want to create your new rule in.

  2. Select Edit Menu > Add Rule Command PPM All Outputs Graphic.

    OR

    Right-click and select Add Rule.

  3. On the General Tab (Rule Properties Dialog), type a name and a description for the rule.

  4. Under Rule Action select either Check data or Control graphic interface.

  5. From the Priority list, select a rule priority.

  6. On the Rule Components Tab (Rule Properties Dialog) under Component1, select next to the Item type field.

  7. On the Select Item selection list, select an item type.

  8. Select Single component.

  9. On the Filter Tab (Rule Properties Dialog), add the criteria for your filter.

  10. On the Consistency Tab (Rule Properties Dialog), add the criteria for the consistency check.

  11. Select OK.

  12. Select File > Save Command Save Icon 16bit.

User interface rules work only with items in property forms (dialogs), they do not work in the Spec module.