Software Requirements - Intergraph Smart Completions - Intergraph Smart Completions Update 15 - Installation & Upgrade

Intergraph Smart Completions Installation (5.3.15)

Language
English
Product
Intergraph Smart Completions
Search by Category
Installation & Upgrade
Smart Completions Version
5.3.15

  • For installing Smart Completions to your system please refer Installation Process.

  • Microsoft Internet Explorer (IE) is no longer supported in any version higher than 4.0. If Microsoft browsers are preferred, you must use Microsoft Edge.

  • Mobile iOS users must download a new app for any version higher than 4.0. The Smart Completions Companion app is available on the Apple Store.

  • A new File Upload Tool is also required for version 4.0 and higher. You can download it from the Smartsupport.com site under View Downloads > Intergraph Smart Completions > Freeware Tools and Utilities