Introduction to the Symbol 2D Environment - Intergraph Smart 3D - Reference Data

Intergraph Smart 3D Structural Detailing Reference Data

PPMProduct
Intergraph Smart 3D
aSubProduct
Structural Detailing
PPMCategory_custom
Reference Data
Version_SThreeD_Custom
12 (2018)

The Symbol 2D environment is a powerful tool that allows you to create custom reference data. This environment uses Rad2D as a foundation for marine-structure-specific tools.

This environment uses templates which you can customize for specific symbol types. You can also create and store layers in these templates.

Each type of Smart 3D symbol has a specific toolbar. Click Tools > Add-Ins to display the list of available toolbars.

Symbol Relationships

The Symbol2D environment uses a system of dimensions and relationships to control symbols. These relationships are critical to proper symbol behavior.

The following tools are available to help you define the relationships:

SmartSketch2D

This tool allows you to choose which relationships to activate. Click Tools > SmartSketch to activate this tool. Only the relationships that you select are available while you are sketching.

While you are sketching, the software displays relationship indicators as you create the elements.

The relationship handles display on the elements after you create the relationships. You can turn the display of these relationship handles with the Relationship Handles command.

  • Relationship handles do not display if you are zoomed out too far to see them. If the relationship handles are not displayed, try zooming in closer to the elements that you want to see.

  • Knowing which relationships are necessary to make a symbol work takes practice. You can use the testing tools to find symbols that are over constrained.

Dimensions

Dimensions in symbols are controlled by rules. You must apply the dimensions correctly for the symbol to adjust properly.

You can control the format of the dimensions in the symbol by clicking Format > Dimensions and changing the values.

To change the way that dimensions display on the ribbon bar, you have to change the units settings for the file. Click File > Properties and select the Units tab to change the units settings for the file.

There are several dimensioning options, but the most commonly used include Smart Dimension, Distance Between, Angle Between, and Axis.

Smart Dimension

Use this option to quickly dimension element lengths or radii. You cannot use Smart Dimension to place dimensions between elements.

Distance Between

Use this option to dimension the distance between two elements. You can select points, lines, center of circles, and so on. There are several commands available to align the dimensions, such as Horizontal/Vertical, Between 2 Points, and Along Axis.

When you align the dimensions using the Horizontal/Vertical command, the dimensions are constrained to remain in the horizontal or vertical direction. Do not use this alignment on symbols that will not always remain orthogonal.

The Between 2 Points alignment is the most commonly used, because it allows the dimension to rotate if necessary.

The Along Axis alignment constrains the dimension to an axis that you define. This alignment does not constrain the dimension to the horizontal or vertical axes.

Angle Between

Use this option to dimension an angle between two elements.

Driving and Driven Dimensions

A driving dimension controls the size or location of an element. That is, the element must change if the dimension changes.

A driven dimension is controlled by the size or location of an element. That is, if the element changes then the dimension must change.

Creating Custom Curves

Most symbols require B-splines for input and output geometry to control the symbol when it is placed on curved structure.

The Custom Curve commands make it easier for you to create and constrain B-spline curves. These commands include Place > Offset Curve with Relationship, Place > Offset Curve with Hint, and Edit > Custom Curve Trim.

Offset Curve with Relationship

This command creates a curve with the same shape as the selected curve, and places a distance dimension.

A - Placement

B - Dimension

Custom Curve Trim

This command is necessary to close symbols that contain a B-spline on an output layer. To use this command, do the following:

  1. Select the B-spline curve near the end that you want to trim. Be sure that you are past the mid-point, or the command will trim the element from the wrong end.

  2. Select the intersection element.

  3. Trim the intersecting element to the B-spline if necessary.

  4. Make sure that a connection constraint was created.