Create a new filter - Intergraph Smart 3D - Help

Intergraph Smart 3D Structural Analysis

PPMProduct
Intergraph Smart 3D
aSubProduct
Structural Analysis
PPMCategory_custom
Help
Version_SThreeD_Custom
12.1 (2019)
  1. Open the Select Filter Dialog Box by doing one of the following:

    Click Tools >Select by Filter.

    Select More from the Filter list on the Define Workspace Dialog Box.

    Select More from the Filter list on the Surface Style Rule Properties Dialog Box.

  2. Click New Filter to create a new filter. Select the type of filter:

    Select Catalog Filters or sub folder under that node to create a new catalog filter.

    Select Plant Filters or sub folder under that node to create a new plant filter.

    Select My Filters or sub folder under that node to create a new personal filter.

    To create a new filter under My Filters folder:

    1. Click File >Define Workspace (CTRL+W).

    2. Select the model from the Plant list.

    3. Select Create New Filter from the Filters.

  3. Type a name for the new filter in the Name box.

    Filter names must be unique within the folder. You can have a filter in your My Filters folder with the same name as a filter in another folder. If you move a filter into a folder that already contains a filter of the same name, the software adds a numeric suffix to the filter name to keep the filter names unique.

  4. Specify the filter search queries using one or more of the tabs on the Filter Properties Dialog Box.

    Include nested objects indicates whether the search to includes all objects within a category. If this option is cleared, you must separately select each category and individual object.

    System Tab (Filter Properties Dialog Box) navigates the tree list to the systems to include in the query. These systems include the model root at the highest point of the hierarchy, as well as all subsystems, and specific types of objects. Select the Include nested objects option, if you want to include all objects under specified System nodes.

    Assembly tab navigates the tree view and select the assemblies to include in the search. Select the Include nested objects option, if you want to include all objects under specified Assembly nodes.

    Named Space tab indicates the named spaces and drawing volumes to include in the search. Select the Include nested objects option, if you want to include all objects under specified Space nodes.

    • A named space is a volume in the model, like a fire or blast zone.

    • A drawing volume defines the clipping volume associated with a specific drawing view in a document.

      Analysis tab selects structural analysis models to include in the search. Select the Include nested objects option, if you want to include all objects under specified Analysis entities.

      Work Breakdown Structure tab identifies components in the Work Breakdown Structure to include in the search. Select the Include nested objects option, if you want to include all objects under specified WBS items.

      Permission Group Tab (Filter Properties Dialog Box) tab navigates the tree list for selecting the permission groups to include in the search.

      Object Type restricts the query to the specific object types with the list of disciplines.

      Volume tab restricts selection. Choose between two options for volume search. Select Named Spaces to designate the named spaces to include. Select Planes to specify certain reference planes or coordinate locations to define the six sides of a box. For objects contained in the volume inside this box, the software includes these objects in the filter.

      Properties tab restricts the search using properties of objects in the data model. For example, you can choose to match all properties listed in the grid, match any property listed in the grid, or use an operator, like equal ( = ) to narrow the search.

    • The Select Properties dialog box browses the data model to select properties on types. In the Property column, click More.

    • The Select Object Type dialog box specifies an object type for a property. You access this dialog box by clicking More in the Object type box on the Select Properties dialog box.

      Reference 3D tab (if available) includes any attached reference 3D models, folders or files in the query.

      Point Cloud tab (if available) includes any point cloud objects in the query.

  5. Click OK on the New Filter dialog box to save the new filter and apply it to the selected objects in the workspace.

  • Use the Configuration tab to designate the options and configuration information for the filter. You can specify filter status and the associated permission group. These settings have no effect on the objects that the search returns. They govern the access permissions on the filter itself.

  • An asking filter can have specific selection of filter definitions excluded, but have the Asking Filter - user of filter will supply value selected. You can specify these values when you use the filter. See Create a new asking filter.

  • A compound filter combines two or more filters by using an operator, such as not, union, or intersection, between the filters to explain the relationship between the filters. See Create a new compound filter.