Reports Common Tasks - Intergraph Smart 3D - Help

Intergraph Smart 3D Reports

Language
English (United States)
Product
Intergraph Smart 3D
Subproduct
Drawings and Reports
Search by Category
Help
Smart 3D Version
11 (2016)
SmartPlant Foundation / SDx Version
7.1 (2018 R1)

The following tasks are used frequently when you create spreadsheet reports.

Create a Spreadsheet Reports Component

You create a Spreadsheet Reports component using New command. For more information, see New Command.

Create the Report or a New Report Template

Right-click on the Spreadsheet Report component and select Create Report to specify the type of report and create it. For more information, see Create a new report template from an existing template and Create and update a delivered report.

Edit the Report

Right-click a report and select Edit Template to activate the Report Template Editor and customize the report. For more information, see Report Template Editor. To customize the appearance of the report, go to the Formatting Tab and click Design Layout to open the report in Excel and modify the appearance and content. For more information, see Design Layout.

Add a Filter-Based Query to a Report

You can add a query to a report. For more information, see Add a filter-based query to a report template.

Create a Filter-Based Report

You can also create a report that is based entirely on filters and object properties. For more information, see Create a filter-based report.

Remove a Report Template Component

A report component is represented as a tab in the Report Template Editor when editing a report template. You use the Tools > Remove: Component command. For more information, see Remove Report Component (Tools Menu).

Update the Report

Update your report or multiple reports using the Update commands. For more information, see Updating Documents.

Setting Report Properties

You can set report properties with the Properties command. For more information, see Edit document properties.

Copying a Report to the Catalog

Copying a new or edited report to the catalog allows everyone to have access to the report. The report is added to the Report hierarchy in the Catalog task and can be run using the Run Report command in other 3D tasks. For more information, see Copy a report template to the catalog.

Save a Report Template

You have two options for saving report templates. You can save a modified report template and its components to the Catalog using the File > Save Report Template command. For more information, see Save Report Template (File Menu). You can also save a selected report template and components to a location that you specify and change the names of report templates and their components before saving. For more information, see Save a report template to a specified location.

Publish the Report

You can publish Spreadsheet Reports if your model has been registered using the SmartPlant Registration Wizard. For more information, see Publishing Documents.

The viewable files created when you publish drawings and reports provide relationship links to the 3D Model Data. You must also publish the 3D Model Data to provide the navigation between the viewable files and the 3D Model Data.