Edit a Report Template - Intergraph Smart 3D - Help - Hexagon PPM

Intergraph Smart 3D Reports

Language
English (United States)
Product
Intergraph Smart 3D
Subproduct
Drawings and Reports
Search by Category
Help
Smart 3D Version
13
SmartPlant Foundation / SDx Version
10
  1. Right-click a report in the Detail View, and click Edit Template.

  2. To modify SQL queries, modify the SQL statements on the appropriate Query tabs to query the databases. Click Show Results Pane to open a lower window that displays the results of the query. Test the query by clicking Execute Query .

    SHARED Tip You can also type a different description for the query in the Description box at the top of the tab.

  3. To modify property-based queries, specify a different filter, or create a new filter in the Filter box on the appropriate Query tabs.

    • You can add or remove properties in the query using the Add and Remove buttons.

    • Filters created with the Create New Filter command must be moved to the Catalog before running the report. Select More in the dropdown to create filters directly in the database.

  4. On the Formatting tab, specify the layout of the report by clicking Design Layout . The software opens a window in Excel.

    SHARED Tip If you have already opened the Excel layout for the template, the software asks if you want to overwrite it in the temporary location.

  5. Select an attribute on the left, click Insert, and then click in the Excel window to place the attribute. You can also drag and drop the attribute from the left pane to the Excel sheet.

  6. Right-click items in the left pane, and click Properties to specify layout properties, such as grouping, sorting, and comparing. For more information, see Properties (Shortcut Menu in Microsoft Excel).

  7. Under Formatting Parameters in the Design Layout hierarchy, click and drag parameters as needed onto the report template sheet.

  8. To add a customized attribute to the report template, right-click the User Defined item and select Properties. On the Define User Item dialog box, you can add new attributes, modify existing attributes, or delete an existing attribute. For more information, see Define User Item Dialog Box.

  9. Save the changes to the template by clicking File > Save Report Template. The software saves the edited template in the Model database.

  10. If you added or modified parameters for any query, right-click the report in the Detail View, and then click Parameters to redefine parameters before you run the report.

  • The software combines the options you set on all the tabs to form the report template. You can add tabs by clicking the commands on the Tools menu. Each report template can have multiple queries and baselines, but only one format and one display.

  • You can save the template in another location by clicking File > Save Report Template As. By default, templates saved using this command are personal reports that you can run in most of the tasks in the software using the My Reports tab of the Run Report dialog box.

  • You can make new report templates available to others by making changes to the names and locations of report templates on the Report sheet of the Reports.xls spreadsheet and then bulk loading the reference data into the Catalog database. All of the report files (.rtp, .rqe, and so on.) must be saved to a folder to which everyone has access, such as the SharedContent folder.