Create a new report template from an existing template - Intergraph Smart 3D - Help - Hexagon PPM

Intergraph Smart 3D Reports

Language
English (United States)
Product
Intergraph Smart 3D
Subproduct
Drawings and Reports
Search by Category
Help
Smart 3D Version
13
SmartPlant Foundation / SDx Version
10

To create a new report template, you can create a report based on an existing template and then make changes to the template. After your changes are made, you can save the existing template with a new name to create a new template.

  1. In the Management Console, right-click a spreadsheet report component, and click Create Report on the shortcut menu.

  2. On the Select Report Template dialog box, click a report template, and click OK.

    • To create a new filter-based report template that returns properties, select one of the delivered reports that contains a property-based query.

    • To create a new report template with a SQL query, select one of the delivered SQL-based reports.

  3. In the Detail View, right-click the report you created and click Edit Template. The report template opens in the Report Template Editor with the first tab of the report template displayed. The following example shows the report template Equipment Finishing Sorted by Equipment Name.

    SHARED Tip Use the arrows at the top of the editor to scroll through the Report Template Editor tabs.

  4. The Query tabs always display first in the tab order. In the example above, notice that there are two query tabs already available. To add a new query, click Tools > Add Query and select the existing query you want to use as a starting point for your new query. When you add a query, the software adds it as a tab to the Report Template Editor. For example, you could add a filter-based query called Processing Equipment and a tab of the same name would be added to the Report Template Editor.

    To set the properties on a filter-based query, see Add a filter-based query to a report template.

  5. To modify queries, modify the statements on the appropriate Query tabs to query the databases. You can edit the existing query, or delete the existing statements and type a new query. You can combine two queries to create a single query. If the query contains parameters, click Edit Query Parameters to make changes to the query prompts presented when the report runs.

    SHARED Tip For more information on using queries and correct formats for SQL Server and ORACLE, see Report Queries to Extract Data.

  6. To modify property-based queries, specify a different filter or create a new filter in the Filter box on the appropriate Query tabs.

    SHARED Tip You can add properties to include in the query by clicking Add. To remove a property, click a row in the table, then click Remove.

  7. Test the query by clicking Execute Query . To see the results of the test, click Show Results Panel .

  8. To add a differential report, use Tools > Add Baseline to add a Baseline tab to specify the differential report.

  9. On the Formatting tab, specify the layout of the report by clicking Design Layout . The software opens the report template in Excel. For more information, see Design Layout.

  10. Select an attribute on the left, click Insert, and then click in the Excel window to place the attribute. You can also drag and drop the attribute from the left pane to the Excel sheet.

  11. Right-click the query in the left pane, and click Properties to specify layout properties such as grouping, sorting, and comparing.

  12. Under Formatting Parameters in the Design Layout hierarchy, click and drag parameters as needed onto the report template sheet.

  13. To add a customizable attribute to the report template, right-click the User Defined item and select Properties. On the Define User Item dialog box, you can add new attributes, modify existing attributes, or delete an existing attribute. For more information, see Define User Item Dialog Box.

  14. Exit Excel, and save the workbook when prompted.

  15. Use File > Save Report Template to save the modified report template and its components to the Catalog. Use the File > Save Report Template As command to save the selected report template and components to a location that you specify. You could also change the names of report templates and their components before saving.

  16. To copy the report template to the database, right click on the report template, and then click Copy to Catalog.

    Copy a report template to the catalog

  • The software combines the options you set on all the tabs to form the report template. You can add tabs by clicking the commands on the Tools menu. Each report template can have multiple queries and baselines, but only one format and one display.

  • If you want your report templates to be available to others, you must make changes to the names and locations of report templates on the Report sheet of the Reports.xls spreadsheet and then bulk load the reference data into the catalog database. All of the report files (.rtp, .rqe, etc.) must be saved to a folder to which everyone has access, such as the SharedContent folder.

  • It is recommended that you save new or modified template files with unique names different from the templates delivered with the software. You should not use the same names as the delivered report templates.