Run Report Command - Intergraph Smart 3D - Help - Hexagon PPM

Intergraph Smart 3D Reports

Language
English (United States)
Product
Intergraph Smart 3D
Subproduct
Drawings and Reports
Search by Category
Help
Smart 3D Version
13
SmartPlant Foundation / SDx Version
10

Runs an existing catalog or personal report. By default, all reports generated with this command are in Microsoft® Excel format (.xlsx). You can use Tools > Run Report to generate reports in any of the 3D tasks.

Reports are divided into two overall categories: catalog reports and personal reports. Catalog reports include report templates delivered with the software and templates that a reports designer has created. Personal reports use templates you create and save.

Depending on the report definition, you may need to specify additional information such as filters or parameters when running a report. Here are some examples.

If a required filter does not exist, a message appears asking you to create the required filter. When you have provided the necessary information, the command displays the report in Excel.

The Tools > Options command allows you to specify the location of personal report templates and report output. On the File Locations tab, you can specify Personal Report Templates and Reports Output locations. You can change these locations to identify any folder accessible from your computer.

If any errors occur during the processing of a report, the command generates an error log called SP3DReports.log in your local Temp folder.

  • For information about creating the Report databases, see the Smart 3D Installation Guide available from the Help > Printable Guides in the software.

  • In the Drawings and Reports task, you can create, modify, update, save as another file, print, and run personal reports. Also, you can save reports to the catalog to be used by other users or publish the reports in an integrated environment. For information on creating report templates or report deliverables, see the Reports User's Guide.

  • Microsoft Excel 32-bit is the supported version for the Drawings and Reports task. Click File > Excel Options. Go to the Trust Center category and select the Trust Center Settings button. Select the Macro Settings category and check Trust access to the VBA project object model.

    For more information about Microsoft Office and service packs, refer to the Microsoft web site.

What do you want to do?