Copy a SIO member to a native Smart 3D member - Intergraph Smart 3D - Administration & Configuration - Hexagon PPM

Intergraph Smart 3D Integration - Project As-Built with HxGN SDx

Language
English (United States)
Product
Intergraph Smart 3D
Search by Category
Administration & Configuration
Smart 3D Version
13
  1. In the Structure task, select the SIO member part or system to copy.

  2. Select Tools > Utilities > Copy SIO Member to Smart 3D to open the Copy SIO Member to Smart 3D Dialog.

    Alternatively, right-click SIO member parts or systems, and then select Copy SIO Member to Smart 3D on the shortcut menu to open the Copy SIO Member to Smart 3D Dialog.

    Copy SIO Member to Smart 3D is only available on the shortcut menu when the select set contains only SIO member parts or SIO member systems. However, Copy SIO Member to Smart 3D is always available under Tools > Utilities in the Structure task.

    Copy SIO Member to Smart 3D DIALOG

  3. Select the input method under What to copy.

  4. Select the target location under Where to place the newly created Smart 3D objects.

  5. On the Options tab, specify the input configuration file in the Configuration file for Copy SIO Member to Smart 3D box.

    Copy SIO Member to Smart 3D_Options DIALOG

  6. Specify the location for the conversion report in the Path of conversion report (Log file is also created under the same directory) box.

  7. On the Copy tab, click Copy to start the process.

    The progress and any messages display in the status bar. Important warning messages and error messages also display in message boxes during the copy process.

    • If you selected Test creation of objects on the Copy tab, the software does not copy the input SIO members as native members. Additionally, only the conversion report file displays when you click Copy.

    • When the process completes:

      • The software displays a message box.

      • The conversion report file and the conversion log file display.

      • The newly created native members display at the same position as the SIO members you copied.

      • The software appends _S3D to the original SIO member name, as shown below.

      • copied SIO member names

      • The software writes warnings, errors, and To Do records to the conversion log file.

      • You can validate copied members using any downstream operations available for standard Smart 3D members.

  8. On the Copy tab, click Show Copy SIO Member to Smart 3D Report to review the conversion report.

  9. On the Copy tab, click Show Copy SIO Member to Smart 3D Log to review the log file.