VDS Software Prerequisites and Requirements - Integration - Ver. 3.7.0.3 - Administration & Configuration - Hexagon

HxGN VDS Install and Setup

Language
English
Product
Integration
Search by Category
Administration & Configuration
VDS Version
3.13

The software listed below applies to both the VDS Web Server and the VDS Application Server components.

  • Microsoft Windows Server 2019 or 2022 (64-bit) Datacenter or Standard edition

  • The Web Server (IIS) role must be installed. In addition to the default settings, include:

    • Common HTTP Features > Static Content

    • Security > Basic Authentication

    • Application Development

      • .NET Extensibility 4.8

      • ASP.NET 4.8

      For Windows Server 2019, .NET Extensibility 4.7 and ASP.NET 4.7 are required

  • The .NET Framework 4.8 feature must be installed. In addition to the default settings, include:

    • WCF Services

      • HTTP Activation

      • Named Pipe Activation

      • TCP Activation

    For Windows Server 2019, the .NET Framework 4.7 feature must be installed.

  • The Windows Process Activation Service feature must be installed. In addition to the default settings, include:

    • Process Model

    • Configuration APIs

The exact version of the following Microsoft components must be installed. Other versions or libraries will not work.

  • Microsoft .NET Core Desktop 5.0 Runtime

  • Microsoft ASP.NET Core Runtime 8.0.4 or later Hosting Bundle

    For the Hosting Bundles to install properly, IIS must already be installed and configured on the server.

  • Microsoft Visual C++ Redistributable for Visual Studio, 2015, 2017, and 2019

  • Microsoft ODBC Driver 17 or later for SQL Server

  • RabbitMQ 3.7 and later

  • Erlang - Install the version of Erlang that is compatible with the version of RabbitMQ you installed.

    If the Erlang and RabbitMQ versions are not compatible, RabbitMQ does not work. Check the Rabbit/Erlang compatibility matrix on the RabbitMQ website.

    • Hexagon recommends that you install RabbitMQ using the default values.

    • Hexagon recommends that you install the rabbitmq_management plugin for easily editing the RabbitMQ configuration.

    • RabbitMQ and Erlang are required for the VDS message queue service.

    • Hexagon recommends that you install Erlang using the default values.