Non-Hexagon files will not open because Apache Tomcat cannot access Brava! logs (retired) - HxGN SDx - HxGN SDx - Reference - Hexagon

HxGN SDx Modified and Retired Functionality

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English
Product
HxGN SDx
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Reference
SmartPlant Foundation / SDx Version
10
SmartPlant Markup Plus Version
10.0 (2019)

This functionality was removed in Update 36 and SmartPlant Markup Plus Server 2019 SP 2.

Problem

You cannot view a non-Hexagon file, and the Apache Tomcat log file indicates that the account running the Apache Tomcat service cannot access the Brava! Enterprise log files. For example, the log file might contain a message similar to one of the following:

10:17:49,354 |-ERROR in ch.qos.logback.core.rolling.RollingFileAppender[rolling] – openFile(C:\Program Files (x86)\SmartPlant\Markup\Brava! Enterprise\Brava! License/log/brava-license-service.txt,true) call failed

java.io.FileNotFoundException:C:\Program Files (x86)\SmartPlant\Markup\Brava! Enterprise\Brava! License/log/brava-license-service.txt (Access is denied)

at at java.io.FileOutputStream.open(Native Method)

at at java.io.FileOutputStream.open(Unknown Source)

at at java.io.FileOutputStream.init(Unknown Source)

at ch.qos.logback.core.recovery.ResilientFileOutputStream<init>(ResilientFileOutputStream.java:26)

at ch.qos.logback.core.FileAppender.openFile(FileAppender.java:204)

or

10:17:49,354 |-ERROR in ch.qos.logback.core.rolling.RollingFileAppender[rolling] – Failed to create parent directories for [C:\Program Files (x86)\SmartPlant\Markup\Brava! Enterprise\Brava! License\log\brava-license-service.txt]

The viewer displays the following message when trying to view the file: Ready to view.

Cause

The account running the Apache Tomcat service cannot access the following Brava! Enterprise log files.

  • The brava-license-service.txt is delivered to the [installation location]\SmartPlant\Markup\Brava! Enterprise\Brava! License\log folder.

  • The brava-enterprise-service.txt is delivered to the [installation location]\SmartPlant\Markup\Brava! Enterprise\Brava! Server\log folder.

Solution

Change the account running the Apache Tomcat service to an account that has full access control to the Brava! Enterprise log files. For help with running Apache Tomcat as a Windows service, refer to the documentation at tomcat.apache.org. For help with services logon accounts, see Windows Help.