Interference Check On - CloudWorx for Intergraph Smart Review - Help

CloudWorx for SmartPlant Review Installation and Help

PPMProduct
CloudWorx for Intergraph Smart Review
aSubProduct
CloudWorx for SmartPlant Review
PPMCategory_custom
Help
Version_SThreeD_Custom
12 (2018)
Version_SPR
13.x(2018)

Accessories > CloudWorx > Inquiry and Measurement > Interference check on

Opens the Interference Settings dialog box to change the interference checking options. It also turns on interference check mode. When interference check mode is on, you can use the SmartPlant Review collision detection to perform interference checking between 3D models and cloud points.

To check interferences:

  1. Click Accessories > CloudWorx > Inquiry and Measurement > Interference check on.

    The Interference Settings dialog box displays.

  2. Change the following options as required, and then click OK to finish.

    • Clipping Only - Computes only the points that are not clipped.

    • Hide Original Points - Hides the original point cloud display and shows only the points that interfere with the CAD object.

    • Initial Point Mode - Defines how to display interfering points. You can select from Don't Show, Show Interfering, or Show Non-interfering modes.

    • Interference Threshold - Defines the minimum distances that the interference checking treats as clashing.

    • Interfering Point Color - Displays the detected points in the specified color.

      You are now in interference check mode.

      From SmartPlant Review:

  3. Click Tools > Collision Detection > Edit Collision Sets.

  4. Select the Type Filter tab.

  5. In the Collision set name box, type in a name.

  6. Under Collision types, select Point cloud intersections.

    Selecting this option runs the elements included in the collision set against the entire point cloud data set, rather than running the collision detection set against other model elements. In other words, selecting a single element compares it against the point cloud data, selecting a display set compares the display set elements against the point cloud data, and selecting a static element run compares elements in the chosen range against the point cloud data.

  7. Click the Selection tab.

  8. Select one of the following options, and then click OK:

    • Single graphic object

    • Display sets

    • Stationary collisions in a selected range cube

  9. Click Tools > Collision Detection > Detect Collisions.

  10. Select the collision set name you previously entered.

  11. Select the object to check, and then click Detect.

    • To change the main view to wireframe so that you can better see the collisions with the Cloudworx points, click View > Display > Wireframe.

    • To change the collision detection color and point size (under Cloudworx preferences) so that it stands out more against the point color, click Tools > Collision Detection > Edit Collision Sets. From the Color tab, select a different Default and Intersecting color.

      A record of each collision run is stored in the point cloud software, rather than being stored in the project database. You only see collisions in the Main view. Collision run information is not generated in the Report section of the Detect Collisions dialog box.

  12. To exit point cloud interference mode, click Accessories > Inquiry and Measurement > Interference Off.

See Also