Add a new data table to a group folder - CADWorx - Help

CADWorx Spec Editor

PPMProduct
CADWorx
PPMCategory_custom
Help
Version_CADWorx
20.1 (2020 R1)

You must set the Data Table List Mode in the View tab to Group List Mode to accomplish the following steps.

  1. Click + on the Data Tables folder in Catalog Data.

    The Data Tables folder expands, displaying the group folders.

  2. Select a folder, or right-click Data Tables, and then select New Group Data Table to add a new group folder.

    Group folders can contain multiple categories and components.

  3. Click the Home tab, and then click Data Table on the Add Tables panel. Alternatively, right-click a category in Data Tables in Catalog Data, and then select Add Data Table .

    The New Data Table dialog box displays.

  4. Type the name of the new data table in the Name box.

    The software populates the Name box with a default if you complete steps 5 and 6 first.

  5. Click the Category list, and then select a category.

    The Category selection determines the Type list contents.

  6. Click the Type list, and then select the type. If you did not type a Name in the name box, then the software auto-populates the box for you.

    If you select a bolt or a gasket, the software then allows you to define the Selection Code. Also, if you select a flange, coupling, or clamped component, the software then allows you to define the Applicable Gasket and Applicable Bolt if you defined the Selection Codes for the gasket and bolts.

  7. Click the Size Table list, and then select a size table.

  8. Click the Size Table ellipsis, select the sizes to add from the Select Size list, and then click OK.

    Use the Select / deselect all check box to select or clear all sizes.

  9. Type the part number in the Part Number box.

  10. Specify a group. You can select a category type or a group folder name from the Group list, or type a group name in the Group box. You can also click the Group ellipsis to add groups through the Group Data Table Manager.

    You must specify a group for any data table you create. The software then places the data table correctly when you switch to the Group List Mode in the View tab on the Data Table List Mode panel.

  11. Click the BOM Type list, and then select a Bill of Material type or use the default BOM type.

  12. Click the Layer Name list, and then select a layer, or use the default layer.

  13. Click the Color Index list, and then select a color, or use the default color.

  14. Click the Topworks list, and then select the topworks when applicable.

  15. Type the Sort Sequence.

  16. Type the Isogen Identifier.

  17. Select an Isogen SKEY.

  18. Use the Optional Component check box to specify whether or not the component is optional.

  19. To apply the same end type on all ends, click the Apply same end-type on all ends check box.

  20. Click the Start list, and then select a start end type for the component. Click the End, Branch 1, and Branch 2 lists, and then select the necessary end types.

    If you select the Apply same end-type to all ends check box, then you cannot select the End, Branch 1, and Branch 2 end types because they take the end type of the Start box. The software only activates the End, Branch 1, and Branch 2 end types when the selected component type has more than one end.

  21. Enter a table description in the Description box.

  22. Click OK.

    The new data table displays in the Main Table List View and in Catalog Data.

  23. Click File > Save to save the changes to the catalog.

See Also

Add MAINSIZE

Add New MAINSIZE

Component Tables