Pipe Support Description Format Dialog Boxes - CADWorx - Help

CADWorx Spec Editor

PPMProduct
CADWorx
PPMCategory_custom
Help
Version_CADWorx
20.1 (2020 R1)

CADWorx Spec Editor View tab: Display > Properties > <Description Type> Format Setup ellipsis

Specifies the description format for a pipe support.

Descriptions display in the Long, Short, Tag, and Part Number boxes for an assembly and in Long, Short, Tag, and Part Number boxes for a part shown in the Pipe support assembly edit dialog box when you double-click a pipe support in CADWorx Plant. For more information, see Local Edit in the CADWorx Plant Users Guide.

The information the software displays in the Pipe support assembly edit dialog box is based on the associated pipe support definition in the specification. The pipe support definition in the specification contains fields for Long, Short, Tag, and Part Number. You can populate these boxes with text data or set the schema in the Pipe Support Long, Short, Tag, and Part Number Format Dialog Boxes or Pipe Support Description Format Dialog Boxes.

You can configure a description schema for the Long, Short, Tag, and Part Number boxes at the libraries level, the library level, the pipe support assembly level, and the pipe support component level. If you define a schema at any of these levels, then the software derives the description from that level.

Pipe support component schemas and pipe support assembly schemas take precedence over pipe support library level schemas, and pipe support library level schemas take precedence over pipe support libraries level schemas. For instance, if the component Beam Clamp has a schema defined, then the information displaying in CADWorx for Beam Clamp derives from this schema. If you remove the schema definition from the Beam Clamp, then when a Beam Clamp places as part of an assembly in the model, the schema derives from the main Pipe Support Library tree description schema.

If you delete all of the description schemas at the pipe support component level or at the pipe support assembly level, then the software repeats the above process at the pipe support library level. Next, the software repeats this process at the libraries level.

When the description format is empty at the component level or the assembly level, then the boxes under Description in the Edit panes read Using Pipe Support Library Format. If the description format is empty at the component level or the assembly level and at the library level, then the boxes under Description in the Edit panes read Using Pipe Support Library Format.

For more information on the pipe support component level and the pipe support assembly level, see Long, Short, Tag, and Part Number Format Dialog Boxes.

Pipe Support Libraries Component List

Displays the available list of pipe support components. The Pipe Support Libraries Component List consists of two levels of formats. The main Pipe Support Libraries level covers all components. Next, the pipe support component level covers each type of component and the steel components. The next level contains the individual components. The software reads the schemas that you place in each of these areas in order from bottom to top. The software always reads the individual components level first. If the individual component format is empty, then the software reads the category component level. If the category component level is empty, then the software reads the main component format.

Tables

Displays a list of tables, which allow you to choose formats to place for descriptions.

  • Size Tables

Lists the format types available for size tables in Table Fields. These properties are contained in the Size Table in the catalog.

  • Pipe Support or Steel Component Table

Lists the format types available for the selected pipe support or steel component in Table Fields. The properties listed come from the components listed under PipeSupport in the Data Tables of the catalog.

  • Pipe Support Libraries Tables

Lists the format types available for pipe support libraries tables in Table Fields. The properties listed come from the Name and Description fields in the Pipe Support Libraries Properties.

  • Pipe Support Library Tables

Lists the format types available for pipe support library tables in Table Fields. The properties listed come from the Name and Description fields in the Pipe Support Library Properties.

Table Fields

Lists the formats for the chosen table, and enables you to add the table field to the format.

<Description Type> Format

Lists the format, and enables you to add the needed formats from the Table Fields box. If you have added a space or text in the Format box, then you can select and edit the space or text. Select the space or text, right-click, and then select Edit.

Format

Displays the appearance of the format. You can add a space or text to the format. Blue words in Format are keywords and can be selected to copy. Black text is a simple text string and can be edited as needed.

Example

Displays an example of the format as it would display in the software.

Import

Imports formats from other projects.

Export

Exports formats for use in other projects.

  1. Open an existing pipe support libraries file, or create a new pipe support libraries file. You can open the <Description Type> Format dialog boxes in both places. If creating a new pipe support libraries file, skip to the second part of step 3.

  2. Click the View tab, and then select Properties in the Display panel.

  3. Click the Long Desc, Short Desc, Tag, or Part Number Format Setup box in the Properties window, and then click .

    OR

    Click Long Desc, Short Desc, Tag, or Part Number in the New Pipe Support Libraries dialog box when creating a new pipe support libraries file.

    The <Description Type> Format dialog box displays.

  4. Select the main Pipe Support Libraries folder, or select a pipe support component from the Pipe Support Libraries Component List.

    You can also import a format, and then edit it as needed. If you import a format and do not want to edit it, skip to step 9.

  5. Select a table from the Tables list above Table fields.

  6. Use the left or right arrows to move table properties from one field to another. Alternatively, you can drag or double-click a format to add it from Table Fields to the Format box.

  7. Use the up or down arrows to move the format.

    If you want to remove a format, select it, and then press DELETE.

  8. To edit the format appearance, select the format in the <Description Type> Format box, and then change the format in the Format box.

  9. Click OK when finished.

    You can export the format for use in other projects or pipe support libraries files.

  10. Click File > Save to save changes to the project.