Add Pipe Support Library - CADWorx - Help

CADWorx Spec Editor

PPMProduct
CADWorx
PPMCategory_custom
Help
Version_CADWorx
20.1 (2020 R1)

CADWorx Spec Editor Project: Home Tab > Pipe Support > Add Pipe Support Library

CADWorx Spec Editor Project: View Tab > Pipe Support Library > Right-click the project in the Pipe Support Library pane > Add Pipe Support Library

CADWorx Spec Editor Pipe Support Library File: Home Tab > Pipe Support > Add Pipe Support Library

CADWorx Spec Editor Pipe Support Library File: View Tab > Pipe Support Library > Right-click the library file in the Pipe Support Library pane > Add Pipe Support Library

Adds a pipe support library to a project or a library file.

For pipe supports to work correctly, you must have a PipeSupport category in the data table of the catalog with all components.

Name

Specifies the name of the pipe support library.

Catalog

Specifies the base catalog.

Size Table

Specifies the size table from the base catalog for use with the pipe support data.

Available Size

Specifies a list of the available sizes from the size table. Select or clear the check boxes in the list to add or remove sizes.

Long Desc Format Setup

Specifies the appearance of the long description attached to the pipe support components.

Short Desc Format Setup

Specifies the appearance of the short description format attached to the pipe support components.

Tag Format Setup

Specifies the appearance of the tag format attached to the pipe support components.

Part Number Format Setup

Specifies the appearance of the part number attached to the pipe support components.

For more on the <Description Type> Format Setups, see Pipe Support Description Format Dialog Boxes.

Created By

Specifies who created the pipe support library.

Description

Specifies the description of the pipe support library.

  1. Click the Home tab, and then click Add Pipe Support Library in the Pipe Support panel. Alternatively, right-click the project or the library file, and then select Add Pipe Support Library.

    The New Pipe Support Library dialog box displays.

  2. Type the name of the new library in the Name box.

  3. Use the default catalog, or click the Catalog ellipsis for a new catalog. When the Select Company Catalog File dialog box displays, select a catalog, and then click Open.

    This catalog must contain a PipeSupport category for the pipe supports to function correctly. To add a pipe support category, see Legacy Catalog Data Panel or to build your own, see Category Table.

  4. Click the Size Table list, and then select a size table.

    The size table you select comes from the catalog that you selected in the last step. If this catalog does not contain a size table, you need to add one before you can add the new pipe support library.

  5. Use the Available Size list to select or clear sizes.

  6. Click Long Desc Format, and then complete the dialog box as needed.

  7. Click Part Number Format, and then complete the dialog box as needed.

  8. Click Short Desc Format, and then complete the dialog box as needed.

  9. Click Tag Format, and then complete the dialog box as needed.

    Click OK in each dialog box when finished. For more information on the format dialog boxes, see Pipe Support Description Format Dialog Boxes.

  10. Type the person or company that created the library in the Created By box.

  11. Type a description of the library in the Description box.

  12. Click OK.

  13. Click File > Save to save the changes to the project.

    The new pipe support assembly displays under the project name in Pipe Support Library.

See Also

Pipe Support Library

Pipe Support Library File Home Tab