Add single new component to a spec - CADWorx - Help

CADWorx Spec Editor

PPMProduct
CADWorx
PPMCategory_custom
Help
Version_CADWorx
20.1 (2020 R1)
  1. Double-click the specification in the Project Specs view.

    The specification displays in the Main Spec List View with the New Component dialog box visible.

    CADWorx displays any default settings already specified in the initial set-up in the boxes.

  2. If the Edit Component pane is visible instead of the New Component pane, then right-click the spec component listing, and then select Add.

    If some of the boxes are not completely visible, increase the height of the pane.

  3. Click the Group list, and then select a group. You can type a name in the Group box, after you select a Category.

  4. Click the Category list, and then select a category. When you select a category from the Category list, the Group automatically changes to the name selected from the Category list.

  5. Click the Type list, and then select a type.

  6. Click the Data Table list, and then select a data table. When you select the Data Table, CADWorx automatically populates the End Type Data Table with the default data from the Default Connection Settings in the base catalog.

    You can view the information you selected by clicking Show Data Table . The Base Catalog Data displays data tables for each component group. For more information, see Base Catalog Data.

  7. Click the Size Range list, and then select or clear the necessary sizes.

  8. Click the BOM Type list, and then select a Bill of Material type or use the default BOM type.

  9. Click the Layer Name list, and then select a layer, or use the default layer.

  10. Click the Color Index list, and then select a color, or use the default color.

  11. Click the IndexCode list, and then select an IndexCode table.

  12. Select the Optional Component check box if you want the component to be optional.

  13. Select the Apply same end type on all ends check box to apply the same end type to all ends on the component.

    The type of component you have selected determines which options are available under the End Type column.

    OR

    1. Click the Start list. Click the plus sign next to the end type to expand the end types, and then double-click an end type table to select it. This list defaults to the Default End Type Data Table Setup for Start in the base catalog, when applicable. You can change Start to something other than the default.

    2. Click the Isogen Sym list, and then select an Isogen symbol for the end type.

    3. Click the End list. Click the plus sign next to the end type to expand the end types, and then double-click an end type table to select it. This defaults to the Default End Type Data Table Setup for End in the base catalog, when applicable. You can change End to something other than the default.

    4. Click the Isogen Sym list, and then select an Isogen symbol for the end type.

    5. Click the Branch1 list. Click the plus sign next to the end type to expand the end types, and then double-click an end type table to select it. This defaults to the Default End Type Data Table Setup for Branch1 in the base catalog, when applicable. You can change Branch1 to something other than the default.

    6. Click the Isogen Sym list, and then select an Isogen symbol for the end type.

    7. Click the Branch2 list. Click the plus sign next to the end type to expand the end types, and then double-click an end type table to select it. This defaults to the Default End Type Data Table Setup for Branch2 in the base catalog, when applicable. You can change Branch2 to something other than the default.

    8. Click the Isogen Sym list, and then select an Isogen symbol for the end type.

  14. Under Isogen Symbol Information, the software should list default data in the Identifier and SKEY boxes. To change the Identifier and SKEY, type your identifier in the Identifier box, and then select your SKEY.

  15. Click the Topworks list, click a topworks folder, and then select the topworks.

  16. Click the Main list, and then select a main schedule.

  17. Click the Reduction list, and then select a reduction schedule.

  18. Click the Material list, and then select a material type.

  19. Under the Rating section, the software lists default values from when you created the specification. Change the Component Class, Temperature Rating, and Pressure Rating values as needed.

  20. The software lists default information for the Sort Sequence. You can change the sort sequence used for the Bill of Materials.

  21. Under the Description column, the software lists a default type of the component for the Long and Short descriptions. You can change the long and short description format by typing new information or using the ellipsis.

  22. Type Tag and Part Number information in their respective boxes.

    OR

    Select the ellipsis to change the format in the Tag Format dialog box or the Part Number Format dialog box. For more information, see Long, Short, Tag, and Part Number Format Dialog Boxes.

  23. Type note information in the Notes box.

  24. Click Add at the top right-hand side of the New component pane.

  25. Click File > Save to save the changes to the project.

    The component adds to the list in the main window.

You can copy and place any component in the Main Spec List View in the same specification or another specification in the current project.

Branch Tab

  1. Click the Branch tab at the bottom of the New component or Edit component pane.

    A grid displays with Branch Size (NPS) on top of the grid, and Main Size (NPS) on the left side of the grid.

  2. To add permitted components to the grid, right-click the applicable main and branch size intersection, and then select one of the types listed. You can modify the grid.

    You must change the Apply Branch Table Rule option, under Piping Rules in CADWorx Plant Setup, to Automatic to apply the branch table settings.

    The grid box displays letters, indicating that you have added a component.

    To add components to multiple intersections at the same time, hold down CTRL while selecting multiple intersections, or left-click a box and drag the mouse in any direction to select multiple boxes.

  3. Click Save when finished. Every time you make a change, you must save the project for the change to take affect.