Introduction to CADWorx Catalog and Specification Editor - CADWorx - Help

CADWorx Spec Editor

PPMProduct
CADWorx
PPMCategory_custom
Help
Version_CADWorx
20.1 (2020 R1)

The CADWorx Catalog and Specification Editor views, edits, and creates specifications and catalog data loaded with CADWorx. The Specification Editor also imports legacy data, and specs from all versions of CADWorx.

Your project administrator needs to review and update the catalog (.cat) and project (.prj) file in the Specification Editor before modeling begins.

Catalog File

Contains all the size, bolt diameters, bolt lengths, materials, schedules, thickness, end types, categories, component data, index codes, database codes, and end prep data for all the components in CADWorx. This is a .cat file, located in [Product Folder]\Plant\Spec, and can only be accessed through the Specification Editor. The catalog file works in conjunction with the project (.prj) file to allow CADWorx to build models.

The areas highlighted in red are referenced throughout this manual. Windows such as the Catalog Data window are referenced by the window name. Please take a moment to get familiar with the interface.

The View tab is explained in View Catalog Tab.

Project File

Contains the specifications for CADWorx. This is a .prj file, located in [Product Folder]\Plant\Spec, and can only be accessed through the Specification Editor. These specifications can be updated by changing the base catalog attached to the project. You can also update the individual components using the Edit Component dialog box. CADWorx uses the project file for specifications and sizes when creating a model.

The areas highlighted in red are referenced throughout this manual. Windows such as the Project Specs window are referenced by the window name. Please take a moment to get familiar with the interface. The Component tab is the default tab when, you open the Main Spec List View.

The View tab is explained in View Project Tab.

Pipe Support Libraries File

Contains a separate pipe support libraries file for CADWorx. This is a .psl file, located in the [Product Folder]\Plant\Spec folder, and can only be accessed through the Specification Editor. CADWorx Spec Editor can use the pipe support libraries file in the Pipe Support Libraries Path to include that libraries file in CADWorx for building pipe support assemblies or to insert pipe supports. This allows you to have more than one set of libraries attached to your specification. You can also build assemblies to add to these pipe support libraries files in CADWorx.

The areas highlighted in red are referenced throughout this manual. Windows such as the Pipe Support Library are referenced by the window name. Please take a moment to get familiar with the interface.

The View tab is explained in Pipe Support Library File View Tab.