Cannot export data to Excel due to an internal server error - HxGN SDx - Update 64 - Administration & Configuration

Administration and Configuration of HxGN SDx

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English
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HxGN SDx
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Administration & Configuration
SmartPlant Foundation / SDx Version
10

Problem

When you want to export all documents in a results grid to Microsoft Excel using the Export All To Excel option, an error 500 message appears.

InternalServerError - Encountered an unexpected error whilst executing ExportAllToExcel, see server logs for more details. Error: A task was canceled.

Causes

This error may occur when a large data set is being sent for export to Microsoft Excel because:

  • The page size is set at too large a value for the export process.

  • The server reaches the ExportToExcelTimeout value for internal server requests.

Solution

You can update the following settings:

  • Change the page size to a lower value using the ExportToExcelMaxPageSize site setting in Server Manager. The default value is set to 300. The minimum value that can be set is 1, and the maximum value is 1000.

  • Increase the internal server request timeout value to a higher value using the ExportToExcelTimeout site setting in Server Manager. The default value is 600 seconds. Increasing the value can help avoid timeout errors when exporting a page with a large amount of data. The minimum value that can be set is 1, and the maximum value is 1000.

We do not recommend you export very large data sets using the Export All to Excel command. You are advised to use reports that have been specifically developed to handle large amounts of complex data. For more information, see Configure reports and Reporting on your data.

Continuous database indexes and compatibility mode changes have helped improve performance and eliminate most export errors.